Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: групповое изменение документов УНФ  (Прочитано 3190 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн PhilRich

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-02
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте уважаемые форумчане!
Заставило меня начальство за новогодние каникулы привести 1С УНФ в порядок) а я в ней сильно не бум-бум)
Надеюсь на вашу помощь) возможно тут смогут ответить на мои вопросы!) 
Есть документы "Заказ покупателя" и "заказ поставщику".
в них есть три состояния заказа: открыт, в работе, закрыт.
нужно внешнюю обработку, которая бы во всех документах со статусом "открыт" или "закрыт" устанавливала статус "в работе".
изменить статус я думаю можно следующей процедурой:

Процедура ИзменитьСтатусЗаказа(Команда)
   
   Если Объект.СостояниеЗаказа.СтатусЗаказа = Перечисления.СтатусыЗаказов.Открыт Тогда
   Объект.СостояниеЗаказа.СтатусЗаказа = Перечисления.СтатусыЗаказов.ВРаботе;
   КонецЕсли;
   
 КонецПроцедуры

а как открывать документы для проверки статуса заказа?

С новым годом!


Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А зачем вам их открывать, если вы их уже поменяли?

Оффлайн PhilRich

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-01-02
  • Сайт: 
  • Профессия: Ученик 1С
Целый день потратил на 5 строк. но я своего добился. может кому пригодится.
Процедура RJV(Команда)
   // Вставить содержимое обработчика.
ДокУст = Документы.ЗаказПокупателя.Выбрать();
СМС = Справочники.СостоянияЗаказовПокупателей.НайтиПоНаименованию("Выполнен");
Враб = Справочники.СостоянияЗаказовПокупателей.НайтиПоНаименованию("В работе");
Пока ДокУст.Следующий() Цикл
   Док2 = ДокУст.ПолучитьОбъект();
   Если ДокУст.СостояниеЗаказа = СМС тогда
       Сообщить(ДокУст.СостояниеЗаказа);
      Док2.СостояниеЗаказа = Враб;
      Док2.Записать();
      
   КОнецесли;
    КонецЦикла;
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
быстрее будет работать в несколько раз если это
Док2 = ДокУст.ПолучитьОбъект();
занести в условие
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3179
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4096
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 173
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3021
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1784
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 797
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal