Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 окт 2021, 00:55

отчет, в котором будут выводится остатки по всем балансовым счетам

Автор Павлов Сергей 48, 20 фев 2010, 13:36

0 Пользователей и 1 гость просматривают эту тему.

Павлов Сергей 48

Помогите написать процедуру! Написать отчет, в котором будут выводится остатки по всем балансовым счетам (из плана счетов), у которых есть ненулевое сальдо на заданную дату (задается в форме).

Или иправить старую проц
Процедура Сформировать()
Таб = СоздатьОбъект("Таблица");//будем все выводить в таблицу
Ит = СоздатьОбъект("БухгалтерскиеИтоги");
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода,,,, 1,, "С"); //выполняем
запрос
Таб.ВывестиСекцию("Шапка"); //выводим заголовок таблицы
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Ит.ВыбратьСчета(); //открываем выборку по счетам
Пока Ит.ПолучитьСчет() = 1 Цикл
сч=Ит.Счет;//получили номер счета
//получаем итоги по каждому счету
СНД=Ит.СНД();
СНК=Ит.СНК();
СКД=Ит.СКД();
СКК=Ит.СКК();
До=Ит.ДО();
КО=Ит.КО();
Таб.ВывестиСекцию("Счет");//выводим итоги в таблицу
КонецЦикла;
//а вот здесь, когда выборка не открыта (или уже закрыта)
//можно получить отоги сразу по всем счетам.
СНД=Ит.СНД();
СНК=Ит.СНК();
СКД=Ит.СКД();
СКК=Ит.СКК();
До=Ит.ДО();
КО=Ит.КО();
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать","");
КонецПроцедуры

Процедура ПриОткрытии()
//это чтобы не вводить каждый раз даты
ВыбНачПериода = НачалоПериодаБИ();
ВыбКонПериода = КонецПериодаБИ();
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск