Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 окт 2021, 23:13

проблема с запросом по регистру

Автор tonio, 18 фев 2010, 20:48

0 Пользователей и 1 гость просматривают эту тему.

tonio

Вообщем имеется регистр, который хранит движения по приходу и расходу товаров!
В данном регистре имеются измерение Товар, ресурс Количество, реквизит Цена!
Вообщем необходимо подсчтитать остаток конкретного товара по документам!
Запускаю вот такой код:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Товар=Регистр.ОстатокТоваров.Товар;
|Цена=Регистр.ОстатокТоваров.Цена;
|Количество=Регистр.ОстатокТоваров.Количество;
|Партия=Регистр.ОстатокТоваров.ТекущийДокумент;
|Условие(Товар=ВыборТовар);
|Группировка Партия упорядочить по Партия.ДатаДок;
|Функция ОстатокПоПартиям=КонОст(Количество);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Сообщить("Запрос не выполнен");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать1");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Пока Запрос.Группировка("Партия",-1)=1 Цикл
Таб.ВывестиСекцию("Товар");
КонецЦикла;
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("","");

Проблема в том, что данный запрос ничего не возвращает,
хотя в регистре имеются данные!Наличие записей в регистре проверял кодом:
  РегТовары = СоздатьОбъект("Регистр.ОстатокТоваров");
РегТовары.УстановитьЗначениеФильтра("Товар",ВыборТовар);
РегТовары.ВыбратьДвижения(НачДата, КонДата);
Пока РегТовары.ПолучитьДвижение()=1 Цикл
Сообщить(РегТовары.Количество);
КонецЦикла;

Вопрос в чем же ошибка, почему запрос ничего не возвращает?

Tatitutu

|Период С <начальная дата> По <конечная дата> ;   
тебе поможет
или функциия приход и расход

*  MAGAZKA - лучшая программа для розничного магазина (с) *

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск