Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 18:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проблема с запросом по регистру  (Прочитано 2381 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tonio

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-11
  • Сайт: 
Вообщем имеется регистр, который хранит движения по приходу и расходу товаров!
В данном регистре имеются измерение Товар, ресурс Количество, реквизит Цена!
Вообщем необходимо подсчтитать остаток конкретного товара по документам!
Запускаю вот такой код:
	Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Товар=Регистр.ОстатокТоваров.Товар;
|Цена=Регистр.ОстатокТоваров.Цена;
|Количество=Регистр.ОстатокТоваров.Количество;
|Партия=Регистр.ОстатокТоваров.ТекущийДокумент;
|Условие(Товар=ВыборТовар);
|Группировка Партия упорядочить по Партия.ДатаДок;
|Функция ОстатокПоПартиям=КонОст(Количество);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Сообщить("Запрос не выполнен");
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать1");
Таб.ВывестиСекцию("Шапка");
Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
Пока Запрос.Группировка("Партия",-1)=1 Цикл
Таб.ВывестиСекцию("Товар");
КонецЦикла;
Таб.ВывестиСекцию("Подвал");
Таб.ТолькоПросмотр(1);
Таб.Показать("","");

Проблема в том, что данный запрос ничего не возвращает,
хотя в регистре имеются данные!Наличие записей в регистре проверял кодом:
  РегТовары = СоздатьОбъект("Регистр.ОстатокТоваров");
РегТовары.УстановитьЗначениеФильтра("Товар",ВыборТовар);
РегТовары.ВыбратьДвижения(НачДата, КонДата);
Пока РегТовары.ПолучитьДвижение()=1 Цикл
Сообщить(РегТовары.Количество);
КонецЦикла;
Вопрос в чем же ошибка, почему запрос ничего не возвращает?


Оффлайн Tatitutu

|Период С <начальная дата> По <конечная дата> ;   
тебе поможет
или функциия приход и расход

*  MAGAZKA - лучшая программа для розничного магазина (с) *


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 360
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal