Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Сен 2020, 16:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сменить значение у регистра сведений  (Прочитано 7335 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pacan4ik

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-18
  • Сайт: 
Парни подскажите!

Хочу сменить значение у регистра сведений ЗначенияСвойствОбъектов, который ссылается на элементы справочника Номенклатура. Вот хотелось бы сменить значение на другой элемент.
Пока дошел до этого момета, и не могу двинуться дальше

Процедура ТестоваяКнопкаНажатие(Элемент)
ОчиститьСообщения();
текТ = Новый ТекстовыйДокумент();
    текТ.Прочитать("D:\cat.txt");
    текТ.Очистить();
текТ.Записать("D:\cat.txt");
регС = РегистрыСведений.ЗначенияСвойствОбъектов.Выбрать();
Пока регС.Следующий() Цикл
Если СокрЛП(регС.Значение) = "БезТорУп" Тогда
Если СокрЛП(регС.Значение.Родитель) = "_Тор" Тогда
Если СокрЛП(регС.Объект.Владелец) = "К20400" Тогда
        знПо = РегС.Значение.ПолучитьОбъект();
        НовоеЗначение = Справочники.Номенклатура.НайтиПоКоду("00000009602");

            Строка0 = Строка(регС.Объект.Владелец);
        Строка1 = Строка(регС.Объект.Наименование);
        текТ.ДобавитьСтроку(Строка0+", "+Строка1);
                                текТ.Записать("D:\cat.txt");
конецЕсли;
конецЕсли;
конецЕсли;
конецЦикла;
КонецПроцедуры




Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
необходимо позиционироваться на записи и изменить ее значение....

Оффлайн Pacan4ik

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-18
  • Сайт: 
необходимо позиционироваться на записи и изменить ее значение....

Интуитивно я, конечно, это понимаю. Но как присвоить НовоеЗначение текущему элементу, полученному через РегС.Значение.ПолучитьОбъект(), если уже начинаем работать с самим элементом справочника,

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
А ти в отладчике просмотри возможно ли изменить данный реквизит при получении его функцией ((ПолучитьОбъект())) - там четко установленно значение возможности изменения

Оффлайн Pacan4ik

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-18
  • Сайт: 
В 8-ке работаю несколько дней, поэтому где в отладчике можно увидеть возможность измененя реквизита пока незнаю

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Встань отладчиком на строчку "знПо = РегС.Значение.ПолучитьОбъект();" и расчитай значение "РегС.Значение.ПолучитьОбъект();" - Открывая эту группировку там увидишь колонку изменения

Оффлайн Pacan4ik

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-18
  • Сайт: 
Этим выражением РегС.Значение.ПолучитьОбъект() мы можем редактировать реквизиты элемента Номеклатуры, а сам элемент сменить не можем

Slin
  • Гость
РегистрСведенийВыборка.<Имя регистра сведений> (InformationRegisterSelection.<Имя регистра сведений>)
ПолучитьМенеджерЗаписи (GetRecordManager)
Синтаксис:
ПолучитьМенеджерЗаписи()
Возвращаемое значение:
Тип: РегистрСведенийМенеджерЗаписи. Менеджер записи регистра сведений.
Описание:
Получает объект для модификации, записи и удаления записи регистра сведений, на которой в данный момент спозиционирована выборка.
Пример:
Процедура КоманднаяПанельВыполнить(Кнопка)
    Рег = РегистрыСведений.ЗначенияПравПользователя;
    Выборка = Рег.Выбрать();
    Пока Выборка.Следующий() Цикл
        Выборка.ПолучитьМенеджерЗаписи().Удалить();
    КонецЦикла;

    Строк = ЭлементыФормы.ТабличноеПоле1.Значение.Количество();
    Для Номер = 0 По Строк-1 Цикл
        Строка = ЭлементыФормы.ТабличноеПоле1.Значение.Получить(Номер);
        Элемент = Рег.СоздатьМенеджерЗаписи();
        Элемент.НаборПрав = Строка.НаборПрав;
        Элемент.Право = Строка.Право;
        Элемент.Значение = Строка.Значение;
        Элемент.Записать();
    КонецЦикла;
КонецПроцедуры


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 11642
Последний ответ 24 Ноя 2014, 12:21
от gigson
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6405
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 7435
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2999
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2517
Последний ответ 02 Дек 2016, 12:58
от Jalib

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
34 Сообщений
oooo800
30 Сообщений
Дмитрий Джей Дмитрий Джей
27 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
IL2016
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 542
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal