Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Мая 2021, 04:28
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Здравствуйте! Подскажите с документом реализация товаров и услуг  (Прочитано 5827 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kosert

  • *
  • Регистрация: 2010-02-15
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
Здравствуйте всем! ))  Подскажите пожалуйста: бухгалтера просят чтобы в документе "реализация товаров и услуг", в поле договор, при выборе контрагента можно было выбрать не только договора с покупателем, но и договора с поставщиком, которые не отображаются в списке договоров контарагента.
Действия: заходим в какой-нибудь документ "реализация товаров и услуг", выбираем контрагента (если нужно, но он уже выбран скорее всего) после начинаем выбирать договор, и открывается список договоро с этим контрагентом, в этом списке есть только договора  покупателем, а как сделать чтобы в списке отображались еще и договора с пставщиком???
Жду ответов и "подбадриваний коллег" ))


Оффлайн kosert

  • *
  • Регистрация: 2010-02-15
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
Предыдущий программист добавлял в модуль документа вот такую штуку: но она че не работает сейчас хотя должна вроде... (после комментария "Добавлено Андрей")
Процедура ДоговорКонтрагентаНачалоВыбора(Элемент, СтандартнаяОбработка)

   // сохраним договор контрагента, возможно понадобится к нему вернуться
   мТекущийДоговорКонтрагента = ДоговорКонтрагента;
   
   //Добавлено  --  Андрей
   Если Контрагент = Справочники.Контрагенты.НайтиПоКоду("00000426 ")
       И мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей
   
    РаботаСДиалогами.НачалоВыбораЗначенияДоговораКонтрагента(ЭтотОбъект, ЭтаФорма, Элемент, Контрагент, ДоговорКонтрагента,
                                 мСписокВидовДоговоров, СтандартнаяОбработка);


КонецПроцедуры // ДоговорКонтрагентаНачалоВыбора()

Оффлайн DDD

  • ****
  • Регистрация: 2008-07-12
  • Сообщений: 374
  • РЕПУТАЦИЯ: 23
  • КПД: 6%
Кусок кода, вставленный Андреем, работает только для одного контрагента, у которого код 00000426. Для остальных контрагентов срабатывать не будет. Если так и было задумано и раньше работало, но сейчас перестало вдруг - посмотрите у того контрагента, не поменялся код?
Или надо, что бы для всех контрагентов это правило срабатывало?

Оффлайн kosert

  • *
  • Регистрация: 2010-02-15
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
я начинаю понимать, и Ваш ответ подтверждает мои мысли. Спасибо!
Надо для всех!
это значит надо получить код текущего контрагента и потом вставить его параметром в ".НайтиПоКоду(ПеременнаяКодТекКонтрагента)", как-то так мне представляется, это корректно будет с точки зрения работы конфигурации?

Оффлайн DDD

  • ****
  • Регистрация: 2008-07-12
  • Сообщений: 374
  • РЕПУТАЦИЯ: 23
  • КПД: 6%
В принципе, такие вещи лучше вообще не делать. Есть договоры с покупателями, есть с поставщиками. И реализация контрагенту по договору с поставщиком - это не правильно. Есть возвраты товара. Или с ним можно заключить договор как с покупателем. Странно, что бухгалтера это от вас требуют.

Но уж если надо:

У меня под рукой 1с нет сейчас, я может всех возможных проблем не вижу, но если вы говорите, что раньше код андрея работал корректно, и вам надо для всех, то попробуйте просто поменять кусок кода:


//Добавлено  --  Андрей
   Если Контрагент = Справочники.Контрагенты.НайтиПоКоду("00000426 ")
       И мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей

на

//Добавлено  --  Андрей
   Если  мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей

Этим мы просто удалили дополнительное условие на контрагента с кодом 00000426

Оффлайн kosert

  • *
  • Регистрация: 2010-02-15
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
Спасибо Большое! Дописал код.
И с Вами согласен по поводу:"В принципе, такие вещи лучше вообще не делать. Есть договоры с покупателями, есть с поставщиками. И реализация контрагенту по договору с поставщиком - это не правильно. Есть возвраты товара. Или с ним можно заключить договор как с покупателем. Странно, что бухгалтера это от вас требуют"
Очень сомневаюсь в корректности работы программы... Ну поживем увидим (Страшня пословица для меня) )))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
32 Сообщений
kiokiosan
17 Сообщений
alexandr_ll
13 Сообщений
DmitriyF DmitriyF
11 Сообщений
Мария2021
9 Сообщений
antoneus antoneus
9 Сообщений
alex0402 alex0402
8 Сообщений
Ивашка
7 Сообщений
kah
7 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск