Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2020, 02:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Здравствуйте! Подскажите с документом реализация товаров и услуг  (Прочитано 5592 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kosert

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-02-15
  • Сайт: 
Здравствуйте всем! ))  Подскажите пожалуйста: бухгалтера просят чтобы в документе "реализация товаров и услуг", в поле договор, при выборе контрагента можно было выбрать не только договора с покупателем, но и договора с поставщиком, которые не отображаются в списке договоров контарагента.
Действия: заходим в какой-нибудь документ "реализация товаров и услуг", выбираем контрагента (если нужно, но он уже выбран скорее всего) после начинаем выбирать договор, и открывается список договоро с этим контрагентом, в этом списке есть только договора  покупателем, а как сделать чтобы в списке отображались еще и договора с пставщиком???
Жду ответов и "подбадриваний коллег" ))


Оффлайн kosert

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-02-15
  • Сайт: 
Предыдущий программист добавлял в модуль документа вот такую штуку: но она че не работает сейчас хотя должна вроде... (после комментария "Добавлено Андрей")
Процедура ДоговорКонтрагентаНачалоВыбора(Элемент, СтандартнаяОбработка)

   // сохраним договор контрагента, возможно понадобится к нему вернуться
   мТекущийДоговорКонтрагента = ДоговорКонтрагента;
   
   //Добавлено  --  Андрей
   Если Контрагент = Справочники.Контрагенты.НайтиПоКоду("00000426 ")
       И мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей
   
    РаботаСДиалогами.НачалоВыбораЗначенияДоговораКонтрагента(ЭтотОбъект, ЭтаФорма, Элемент, Контрагент, ДоговорКонтрагента,
                                 мСписокВидовДоговоров, СтандартнаяОбработка);


КонецПроцедуры // ДоговорКонтрагентаНачалоВыбора()

Оффлайн DDD

  • ****
  • Сообщений: 374
  • РЕПУТАЦИЯ: 23
  • КПД: 6%
  • Регистрация: 2008-07-12
  • Сайт: 
Кусок кода, вставленный Андреем, работает только для одного контрагента, у которого код 00000426. Для остальных контрагентов срабатывать не будет. Если так и было задумано и раньше работало, но сейчас перестало вдруг - посмотрите у того контрагента, не поменялся код?
Или надо, что бы для всех контрагентов это правило срабатывало?

Оффлайн kosert

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-02-15
  • Сайт: 
я начинаю понимать, и Ваш ответ подтверждает мои мысли. Спасибо!
Надо для всех!
это значит надо получить код текущего контрагента и потом вставить его параметром в ".НайтиПоКоду(ПеременнаяКодТекКонтрагента)", как-то так мне представляется, это корректно будет с точки зрения работы конфигурации?

Оффлайн DDD

  • ****
  • Сообщений: 374
  • РЕПУТАЦИЯ: 23
  • КПД: 6%
  • Регистрация: 2008-07-12
  • Сайт: 
В принципе, такие вещи лучше вообще не делать. Есть договоры с покупателями, есть с поставщиками. И реализация контрагенту по договору с поставщиком - это не правильно. Есть возвраты товара. Или с ним можно заключить договор как с покупателем. Странно, что бухгалтера это от вас требуют.

Но уж если надо:

У меня под рукой 1с нет сейчас, я может всех возможных проблем не вижу, но если вы говорите, что раньше код андрея работал корректно, и вам надо для всех, то попробуйте просто поменять кусок кода:


//Добавлено  --  Андрей
   Если Контрагент = Справочники.Контрагенты.НайтиПоКоду("00000426 ")
       И мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей

на

//Добавлено  --  Андрей
   Если  мСписокВидовДоговоров.НайтиПоЗначению(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком) = Неопределено Тогда
          мСписокВидовДоговоров.Добавить(Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком);
   КонецЕсли;
    //Конец Добавлено  --  Андрей

Этим мы просто удалили дополнительное условие на контрагента с кодом 00000426

Оффлайн kosert

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-02-15
  • Сайт: 
Спасибо Большое! Дописал код.
И с Вами согласен по поводу:"В принципе, такие вещи лучше вообще не делать. Есть договоры с покупателями, есть с поставщиками. И реализация контрагенту по договору с поставщиком - это не правильно. Есть возвраты товара. Или с ним можно заключить договор как с покупателем. Странно, что бухгалтера это от вас требуют"
Очень сомневаюсь в корректности работы программы... Ну поживем увидим (Страшня пословица для меня) )))


Теги:
 

В 1с предприятие 8.3 управление торговлей 11.1 как изменить цену на несколько товаров с одним и тем же артиклем на последнюю введенную цену с помощью загрузки обработки или как это сделать в 1с с помощью программирования? прилагаю полный текст обработки

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 869
Последний ответ 11 Фев 2019, 15:15
от сергей123
при загрузке цен в 1с предприятие управление торговлей 11.1 возникают дубли товаров разной цены, т.e. новый товар при загрузке не суммируется с уже загруженным. как можно объединять при загрузке товары с последней загруженной ценой товара? Есть ли такая о

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1291
Последний ответ 01 Авг 2019, 12:43
от Геннадий ОбьГЭС
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1890
Последний ответ 24 Янв 2018, 02:38
от Геннадий ОбьГЭС
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 6951
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3094
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
oooo800
39 Сообщений
LexaK
31 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
24 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
illiona
10 Сообщений

* Кто онлайн

  • Точка Гостей: 224
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal