Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Табличное поле  (Прочитано 1144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите как при добавлении строки в табличное поле документа автоматически выводить текущую дату в отдельной колонке?
Сделал вот так но не работает



Процедура ТоварыПередНачаломДобавления(Элемент, Отказ, Копирование)
   
   ТекДата = НачалоДня(ТекущаяДата());
   зДатаСтроки = ЭлементыФормы.Товары.ТекущиеДанные.ДатаСтр;
   Если Не ЭлементыФормы.Товары.ТекущаяСтрока = Неопределено Тогда
   зДатаСтроки = НачалоДня(ТекущаяДата());
КонецЕсли;
КонецПроцедуры


Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Re: Табличное поле
« Ответ #1: 12 Дек 2012, 14:31 »
точнее вот так

Процедура ТоварыПередНачаломДобавления(Элемент, Отказ, Копирование)
ТекДата = НачалоДня(ТекущаяДата());
зДатаСтроки = ЭлементыФормы.Товары.ТекущиеДанные.ДатаСтр;
зДатаСтроки = НачалоДня(ТекущаяДата());
КонецПроцедуры

Добавлено: 12 Дек 2012, 15:06

Разобрался!

Последний раз редактировалось: lia171; 12 Дек 2012, 15:06


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6914
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2278
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 304
Последний ответ 10 Окт 2017, 12:33
от kiksi
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6381
Последний ответ 10 Июл 2014, 15:16
от virtus
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1072
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 296
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal