Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не работает код из обработки проведения  (Прочитано 3648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mrdil

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ОбработкаПроведения() 
Перем Кол;
Кол = 0;

ТЗ = СоздатьОбъект("ТаблицаЗначений");

ТЗ.ВыбратьСтроки();
Пока ТЗ.ПолучитьСтроку()=1 Цикл
Кол = Кол + 1;
КонецЦикла;

Регистр.Остаток.Оборудование= "" + Наименование;
Регистр.Остаток.Количество=Кол;
Регистр.Остаток.ДвижениеПриходВыполнить();

КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 12 Дек 2012, 13:42


Оффлайн mrdil

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-12
  • Сайт: 
  • Профессия: Ученик 1С
При проведении документа в ресурс регистра "количество" должно плюсоваться значение равное количеству строк табличной части документа, однако этого не происходит. Что я неправильно делаю?

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Наверное, еще нужен код, который будет заполнять таблицу. Пока вы просто создаете пустую таблицу и пытаетесь пробежаться по ней циклом.

Оффлайн mrdil

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Наверное, еще нужен код, который будет заполнять таблицу. Пока вы просто создаете пустую таблицу и пытаетесь пробежаться по ней циклом.

Таблица заполняется данными при формировании документа в режиме Предприятие, потом проводится документа. И в момент проведения должно количество строк посчитаться в таблице и приплюсоваться к количеству в регистре.

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Таблица заполняется данными при формировании документа в режиме Предприятие, потом проводится документа. И в момент проведения должно количество строк посчитаться в таблице и приплюсоваться к количеству в регистре.

она у вас пустая.

между
 ТЗ = СоздатьОбъект("ТаблицаЗначений");  

и между
 ТЗ.ВыбратьСтроки();  

у вас она не заполняется, поэтому пустая. а то что у вас в другом месте она заполняется, никого не колышет. методом СоздатьОбъект("ТаблицаЗначений") вы ее затираете и снова создаете, но уже пустую.

В школу вам надо)  изучать азы информатики)


Оффлайн start2000

  • **
  • Сообщений: 73
  • РЕПУТАЦИЯ: 29
  • КПД: 40%
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Программист 7.7
Попробуйте так:

Процедура ОбработкаПроведения() 

Регистр.Остаток.Оборудование = "" + Наименование;
Регистр.Остаток.Количество = КоличествоСтрок();
Регистр.Остаток.ДвижениеПриходВыполнить();

КонецПроцедуры
[/quote]
если помог, то смело жми Спасибо!

Оффлайн mrdil

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте так:

Процедура ОбработкаПроведения() 

Регистр.Остаток.Оборудование = "" + Наименование;
Регистр.Остаток.Количество = КоличествоСтрок();
Регистр.Остаток.ДвижениеПриходВыполнить();

КонецПроцедуры

[/quote]

Спасибо большое. Короткий прямой ответ, который решил мою проблему.

Herby, информатика  не причем. 1С - специфичная область. Я к ней не имею отношения. Просто возникла задача по 1С, которую я сделаю и больше не прикоснусь к этой области вероятнее всего.

Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Herby, информатика  не причем. 1С - специфичная область. Я к ней не имею отношения. Просто возникла задача по 1С, которую я сделаю и больше не прикоснусь к этой области вероятнее всего.

ничего специфичного здесь нет, обычный скриптовый язык на базе Visual Basic.

а информатика здесь действительно не причем, скорее арифметика.

 Если А присвоить В
  (А:= В)

а потом присвоить С

  (А:= С)

то вопрос: чему теперь равно А?

Если эти простые вычисления переложить на Ваш код, то по Вашему мнению  А должна равняться именно В,
но тупой компьютер почему-то говорит что равно C.

Согласитесь, что бред, но в Вашем примере и в Вашем объяснении своей проблемы именно так и есть.

Поэтому я и написал про азы. Если к программированию имеете отношение, то стыдно такие вопросы задавать, а если же нет, то пусть эту задачу делают, те кто может, а то ваша фраза "Просто возникла задача по 1С, которую я сделаю" слишком самоуверенно звучит. Не Вы сделали, а Вам подсказали как сделать.


Оффлайн mrdil

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-12
  • Сайт: 
  • Профессия: Ученик 1С
Herby, информатика  не причем. 1С - специфичная область. Я к ней не имею отношения. Просто возникла задача по 1С, которую я сделаю и больше не прикоснусь к этой области вероятнее всего.

ничего специфичного здесь нет, обычный скриптовый язык на базе Visual Basic.

а информатика здесь действительно не причем, скорее арифметика.

 Если А присвоить В
  (А:= В)

а потом присвоить С

  (А:= С)

то вопрос: чему теперь равно А?

Если эти простые вычисления переложить на Ваш код, то по Вашему мнению  А должна равняться именно В,
но тупой компьютер почему-то говорит что равно C.

Согласитесь, что бред, но в Вашем примере и в Вашем объяснении своей проблемы именно так и есть.

Поэтому я и написал про азы. Если к программированию имеете отношение, то стыдно такие вопросы задавать, а если же нет, то пусть эту задачу делают, те кто может, а то ваша фраза "Просто возникла задача по 1С, которую я сделаю" слишком самоуверенно звучит. Не Вы сделали, а Вам подсказали как сделать.


Herby, информатика  не причем. 1С - специфичная область. Я к ней не имею отношения. Просто возникла задача по 1С, которую я сделаю и больше не прикоснусь к этой области вероятнее всего.

ничего специфичного здесь нет, обычный скриптовый язык на базе Visual Basic.

а информатика здесь действительно не причем, скорее арифметика.

 Если А присвоить В
  (А:= В)

а потом присвоить С

  (А:= С)

то вопрос: чему теперь равно А?

Если эти простые вычисления переложить на Ваш код, то по Вашему мнению  А должна равняться именно В,
но тупой компьютер почему-то говорит что равно C.

Согласитесь, что бред, но в Вашем примере и в Вашем объяснении своей проблемы именно так и есть.

Поэтому я и написал про азы. Если к программированию имеете отношение, то стыдно такие вопросы задавать, а если же нет, то пусть эту задачу делают, те кто может, а то ваша фраза "Просто возникла задача по 1С, которую я сделаю" слишком самоуверенно звучит. Не Вы сделали, а Вам подсказали как сделать.




То, что я здесь спросил, это лишь малая часть того, что я уже сделал по данной задаче. Я имею дело с программированием довольно давно - С, PHP. И поверьте, отличие ощутимое. Разработку конфигураций в 1С сложно назвать программированием, здесь просто надо знать принцип работы платформы. Слишком углубляться мне не нужно, поэтому попросил помощи. А Вы если такой умный, если уж не помогли, то оставьте свои умные мысли для своей работы.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal