Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2020, 21:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: НЕ работает БухИтоги.ПолучитьСчет()  (Прочитано 2912 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mik_8

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-15
  • Сайт: 
не работает не могу понять почему, при СчетУчета="41.1" БухИтоги.ПолучитьСчет(, ТаблицаОстатков.СчетУчета)=0
при СчетУчета="10" все нормально =1

   БИТовары.ИспользоватьСубконто(ВидыСубконто.Номенклатура,СписокТоваров,2);
   БИТовары.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
   БИТовары.ВключатьСубсчета(-1);
   БИТовары.ВыполнитьЗапрос(,ТекущийДокумент(), "41,41.1, 41.2, 41.3, 41.4",,,,, "СК");
ТаблицаОстатков = СоздатьОбъект("ТаблицаЗначений");
   ВыгрузитьТабличнуюЧасть(ТаблицаОстатков, "Материал, КоличествоОтпущено");
   ТаблицаОстатков.Свернуть("Материал", "КоличествоОтпущено");
   ТаблицаОстатков.НоваяКолонка("КоличествоНаСкладах", "Число");
   ТаблицаОстатков.НоваяКолонка("СуммаНаСкладах", "Число");
   ТаблицаОстатков.НоваяКолонка("СредняяСтоимость", "Число");
   ТаблицаОстатков.НоваяКолонка("СчетУчета");
   ТаблицаОстатков.НоваяКолонка("КоличествоНаСкладахНУ", "Число");
   ТаблицаОстатков.НоваяКолонка("СуммаНаСкладахНУ", "Число");
   ТаблицаОстатков.НоваяКолонка("СчетУчетаНУ");   
   ТаблицаОстатков.НоваяКолонка("КоличествоИнвентаряНаСкладахНУ", "Число");
   ТаблицаОстатков.ВыбратьСтроки();
......
ИначеЕсли ТаблицаОстатков.Материал.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
            ТаблицаОстатков.СчетУчета=Сч41;
            БухИтоги=БИТовары;
.......
                БухИтоги.ВыбратьСчета();
      Если БухИтоги.ПолучитьСчет(, ТаблицаОстатков.СчетУчета) = 1 Тогда
         Если БухИтоги.ПолучитьСубконто(1,, ТаблицаОстатков.Материал) = 1 Тогда
            ТаблицаОстатков.СуммаНаСкладах = Макс(БухИтоги.СКД("С"), 0);
            ТаблицаОстатков.КоличествоНаСкладах = БухИтоги.СКД("К");
            Если БухИтоги.ПолучитьСубконто(ВидыСубконто.МестаХранения,, МестоХранения) = 1 Тогда
               КоличествоНаСкладе = БухИтоги.СКД("К");
            КонецЕсли;
         КонецЕсли;
      КонецЕсли;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
33 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
28 Сообщений
IL2016
25 Сообщений
antoneus antoneus
21 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
SoOliateR
15 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 190
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal