Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 02:57

НЕ работает БухИтоги.ПолучитьСчет()

Автор mik_8, 15 фев 2010, 08:57

0 Пользователей и 1 гость просматривают эту тему.

mik_8

не работает не могу понять почему, при СчетУчета="41.1" БухИтоги.ПолучитьСчет(, ТаблицаОстатков.СчетУчета)=0
при СчетУчета="10" все нормально =1

   БИТовары.ИспользоватьСубконто(ВидыСубконто.Номенклатура,СписокТоваров,2);
   БИТовары.ИспользоватьСубконто(ВидыСубконто.МестаХранения);
   БИТовары.ВключатьСубсчета(-1);
   БИТовары.ВыполнитьЗапрос(,ТекущийДокумент(), "41,41.1, 41.2, 41.3, 41.4",,,,, "СК");
ТаблицаОстатков = СоздатьОбъект("ТаблицаЗначений");
   ВыгрузитьТабличнуюЧасть(ТаблицаОстатков, "Материал, КоличествоОтпущено");
   ТаблицаОстатков.Свернуть("Материал", "КоличествоОтпущено");
   ТаблицаОстатков.НоваяКолонка("КоличествоНаСкладах", "Число");
   ТаблицаОстатков.НоваяКолонка("СуммаНаСкладах", "Число");
   ТаблицаОстатков.НоваяКолонка("СредняяСтоимость", "Число");
   ТаблицаОстатков.НоваяКолонка("СчетУчета");
   ТаблицаОстатков.НоваяКолонка("КоличествоНаСкладахНУ", "Число");
   ТаблицаОстатков.НоваяКолонка("СуммаНаСкладахНУ", "Число");
   ТаблицаОстатков.НоваяКолонка("СчетУчетаНУ");   
   ТаблицаОстатков.НоваяКолонка("КоличествоИнвентаряНаСкладахНУ", "Число");
   ТаблицаОстатков.ВыбратьСтроки();
......
ИначеЕсли ТаблицаОстатков.Материал.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Товар Тогда
            ТаблицаОстатков.СчетУчета=Сч41;
            БухИтоги=БИТовары;
.......
                БухИтоги.ВыбратьСчета();
      Если БухИтоги.ПолучитьСчет(, ТаблицаОстатков.СчетУчета) = 1 Тогда
         Если БухИтоги.ПолучитьСубконто(1,, ТаблицаОстатков.Материал) = 1 Тогда
            ТаблицаОстатков.СуммаНаСкладах = Макс(БухИтоги.СКД("С"), 0);
            ТаблицаОстатков.КоличествоНаСкладах = БухИтоги.СКД("К");
            Если БухИтоги.ПолучитьСубконто(ВидыСубконто.МестаХранения,, МестоХранения) = 1 Тогда
               КоличествоНаСкладе = БухИтоги.СКД("К");
            КонецЕсли;
         КонецЕсли;
      КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск