Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 03:26

Сортировка по дате

Автор Шиншилка, 12 фев 2010, 10:43

0 Пользователей и 1 гость просматривают эту тему.

Шиншилка

Форум 1С:
Программистам. Бухгалтерам. Администраторам. Пользователям   2010 Февраля 12
   Начало             Помощь             Поиск             Профиль             Личные сообщения             Календарь             Выйти       


Здравствуйте, Шиншилка!
Показать новые сообщения с Вашего последнего визита.
Показать новые ответы на Ваши сообщения.



Форум 1С. Программистам. Бухгалтерам. Администраторам. Пользователям. > Форум 1С - ПРЕДПРИЯТИЕ 8.0 8.1 8.2 > Конфигурирование, программирование в "1С - Предприятие 8" > Новая тема
Сортировка по дате
В отчете нужно сформировать сортировку по дате, нашла пример, пишу код и НЕ работает. Подскажите, пожалуйста, что не так. Вод код:


перем Настройки;
перем ПараметрДанныхНачалоПериода,ПараметрДанныхКонецПериода,ИменованныйОтбор;

Процедура ДатаНачалаПриИзменении(Элемент)
ПараметрДанныхНачалоПериода.Значение=ДатаНачала;
КонецПроцедуры

Процедура ДатаОкончанияПриИзменении(Элемент)
ПараметрДанныхКонецПериода.Значение=ДатаОкончания;
КонецПроцедуры

Процедура ИспользованиеОтбораПриИзменении(Элемент)
ИменованныйОтбор.Использование=ИспользованиеОтбора;
КонецПроцедуры

Процедура ПриОткрытии()
СхемаКомпоновкиДанных=Отчеты.РасчетОбъемаУЗИИсследований.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
Настройки=СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
УстановитьНастройки();
СформироватьОтчет();
КонецПроцедуры

Процедура СформироватьОтчет() Экспорт
Настройки=КомпоновщикНастроек.Настройки;
ДанныеРасшифровки=Новый ДанныеРасшифровкиКомпоновкиДанных;
КомпоновщикМакета=Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки=КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровки);

ПроцессорКомпоновкиДанных=Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,,ДанныеРасшифровки);

ЭлементыФормы.Результат.Очистить();
ДокументРезультат=ЭлементыФормы.Результат;
ПроцессорВывода=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
КонецПроцедуры

Процедура УстановитьНастройки()
//ДатаНачала=НачалоГода(РабочаяДата);
//ДатаОкончания=КонецМесяца(РабочаяДата);

ДатаНачала=НачалоГода(ТекущаяДата());
ДатаОкончания=НачалоМесяца(ТекущаяДата());

ПараметрДанныхНачалоПериода=КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы
;
ПараметрДанныхНачалоПериода.Значение=ДатаНачала;
ПараметрДанныхНачалоПериода.Использование=Истина;
   
ПараметрДанныхКонецПериода=КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[1];
ПараметрДанныхКонецПериода.Значение=ДатаОкончания;
ПараметрДанныхКонецПериода.Использование=Истина;
   
//ИменованныйОтбор=КомпоновщикНастроек.Настройки.Отбор.Элементы
;
//ИспользованиеОтбора=ИменованныйОтбор.Использование;
//ПредставлениеОтбора=ИменованныйОтбор.Представление;

ПараметрыВывода=КомпоновщикНастроек.Настройки.ПараметрыВывода;
ПараметрВыводОтбора=ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВыводитьОтбор"));
ПараметрВыводОтбора.Использование=Истина;
ПараметрВыводОтбора.Значение=ТипВыводаТекстаКомпоновкиДанных.НеВыводить;
ПараметрВыводПараметров=ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВыводитьПараметрыДанных"));
ПараметрВыводПараметров.Использование=Истина;
ПараметрВыводПараметров.Значение=ТипВыводаТекстаКомпоновкиДанных.НеВыводить;

Настройки=КомпоновщикНастроек.Настройки;
КонецПроцедуры;



Заранее спасибо.

 
   

                          

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск