Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Сен 2020, 20:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сортировка по дате  (Прочитано 5421 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Шиншилка

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-02-12
  • Сайт: 
Форум 1С:
Программистам. Бухгалтерам. Администраторам. Пользователям   2010 Февраля 12
   Начало             Помощь             Поиск             Профиль             Личные сообщения             Календарь             Выйти       

 
Здравствуйте, Шиншилка!
Показать новые сообщения с Вашего последнего визита.
Показать новые ответы на Ваши сообщения.

 
 
Форум 1С. Программистам. Бухгалтерам. Администраторам. Пользователям. > Форум 1С - ПРЕДПРИЯТИЕ 8.0 8.1 8.2 > Конфигурирование, программирование в "1С - Предприятие 8" > Новая тема
Сортировка по дате
В отчете нужно сформировать сортировку по дате, нашла пример, пишу код и НЕ работает. Подскажите, пожалуйста, что не так. Вод код:


перем Настройки;
перем ПараметрДанныхНачалоПериода,ПараметрДанныхКонецПериода,ИменованныйОтбор;

Процедура ДатаНачалаПриИзменении(Элемент)
 ПараметрДанныхНачалоПериода.Значение=ДатаНачала;
КонецПроцедуры

Процедура ДатаОкончанияПриИзменении(Элемент)
 ПараметрДанныхКонецПериода.Значение=ДатаОкончания;
КонецПроцедуры

Процедура ИспользованиеОтбораПриИзменении(Элемент)
 ИменованныйОтбор.Использование=ИспользованиеОтбора;
КонецПроцедуры

Процедура ПриОткрытии()
 СхемаКомпоновкиДанных=Отчеты.РасчетОбъемаУЗИИсследований.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
 Настройки=СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
 УстановитьНастройки();
 СформироватьОтчет();
КонецПроцедуры

Процедура СформироватьОтчет() Экспорт
 Настройки=КомпоновщикНастроек.Настройки;
 ДанныеРасшифровки=Новый ДанныеРасшифровкиКомпоновкиДанных;
 КомпоновщикМакета=Новый КомпоновщикМакетаКомпоновкиДанных;
 МакетКомпоновки=КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровки);
 
 ПроцессорКомпоновкиДанных=Новый ПроцессорКомпоновкиДанных;
 ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,,ДанныеРасшифровки);
 
 ЭлементыФормы.Результат.Очистить();
 ДокументРезультат=ЭлементыФормы.Результат;
 ПроцессорВывода=Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
 ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
 ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
КонецПроцедуры

Процедура УстановитьНастройки()
 //ДатаНачала=НачалоГода(РабочаяДата);
 //ДатаОкончания=КонецМесяца(РабочаяДата);
 
 ДатаНачала=НачалоГода(ТекущаяДата());
 ДатаОкончания=НачалоМесяца(ТекущаяДата());
 
 ПараметрДанныхНачалоПериода=КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы
;
ПараметрДанныхНачалоПериода.Значение=ДатаНачала;
 ПараметрДанныхНачалоПериода.Использование=Истина;
   
 ПараметрДанныхКонецПериода=КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[1];
 ПараметрДанныхКонецПериода.Значение=ДатаОкончания;
 ПараметрДанныхКонецПериода.Использование=Истина;
   
 //ИменованныйОтбор=КомпоновщикНастроек.Настройки.Отбор.Элементы
;
//ИспользованиеОтбора=ИменованныйОтбор.Использование;
 //ПредставлениеОтбора=ИменованныйОтбор.Представление;
 
 ПараметрыВывода=КомпоновщикНастроек.Настройки.ПараметрыВывода;
 ПараметрВыводОтбора=ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВыводитьОтбор"));
 ПараметрВыводОтбора.Использование=Истина;
 ПараметрВыводОтбора.Значение=ТипВыводаТекстаКомпоновкиДанных.НеВыводить;
 ПараметрВыводПараметров=ПараметрыВывода.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ВыводитьПараметрыДанных"));
 ПараметрВыводПараметров.Использование=Истина;
 ПараметрВыводПараметров.Значение=ТипВыводаТекстаКомпоновкиДанных.НеВыводить;
 
 Настройки=КомпоновщикНастроек.Настройки;
КонецПроцедуры;

 

Заранее спасибо.

 
   
 
                          


Теги:
 

Сортировка журнала документа по полю "ВидДокумента"

Автор greenLissРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4920
Последний ответ 25 Июл 2014, 16:45
от greenLiss
сортировка списка в Форме Выбора Печатных Форм Объекта

Автор evgi73Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 8360
Последний ответ 16 Май 2012, 15:38
от evgi73
После обновления в динамическом списке пропала сортировка по наименованию

Автор Arseniy AgeevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1001
Последний ответ 25 Фев 2017, 18:33
от Arseniy Ageev
1С УНФ 1.6_Фиксация левого столбца в отчетах и сортировка по итоговому полю

Автор EvgenyBuhРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 524
Последний ответ 11 Янв 2019, 16:16
от EvgenyBuh
Сортировка и кнопка настроить список в табличной части

Автор olegspectrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 9950
Последний ответ 15 Июл 2015, 10:49
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
71 Сообщений
oooo800
39 Сообщений
LexaK
32 Сообщений
Дмитрий Джей Дмитрий Джей
29 Сообщений
IL2016
28 Сообщений
antoneus antoneus
26 Сообщений
DmitriyF DmitriyF
18 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
SoOliateR
13 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal