Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ввод на основании  (Прочитано 2260 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Добавил в табличное поле формы документа1 флажок типа булево, нужно что бы при вводе на основании документа1 в документ2 переносились только те строки в которой флажок=Истина, а остальные строки не переносились.



Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Ну проверять этот флажок при вводе на основании и переносить только те где стоит Истина.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Для каждого Элемент из Основание.ТабличнаяЧасть Цикл

   Если Элемент.Галочка Тогда
      НоваяСтрока = ТабличнаяЧасть.Добавить();
      ЗаполнитьЗначенияСвойств(НоваяСтрока,Элемент);
   КонецЕсли;

КонецЦикла;

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо!
Добавлено: 11 Дек 2012, 12:53

Единственное проблема осталась в том что если стоит Ложь то не переносится ни чего, а если истина установлена в любой из строк докмента1 то переносится все в документ2, как сделать что бы переносил только отмеченные?

Последний раз редактировалось: lia171; 11 Дек 2012, 12:53

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Приведите программный код.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Вот код который я написал:

Для Каждого Стр из Основание.Товары Цикл
Если Стр.ПодтверждениеОПереносе = Истина Тогда
Пока Выборка.Следующий() Цикл
СтрокаТабличнойЧасти = Товары.Добавить();
СтрокаТабличнойЧасти.Примечание = Выборка.Примечание;
СтрокаТабличнойЧасти.Номенклатура = Выборка.Номенклатура;
СтрокаТабличнойЧасти.Количество = Выборка.Количество;
СтрокаТабличнойЧасти.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
СтрокаТабличнойЧасти.Коэффициент = Выборка.Коэффициент;
СтрокаТабличнойЧасти.ОбщийВес = Выборка.ОбщийВес;
СтрокаТабличнойЧасти.СоставМатериала = Выборка.СоставМатериала;
СтрокаТабличнойЧасти.ДополнительныеПояснения = Выборка.ДополнительныеПояснения;
СтрокаТабличнойЧасти.Работы = Выборка.Работы;
СтрокаТабличнойЧасти.Запас = Выборка.Запас;
СтрокаТабличнойЧасти.Запас = Выборка.ПодтверждениеОПереносе
КонецЦикла;
КонецЕсли;
КонецЦикла;

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Что называется найдите 10 отличий.

Пока Выборка.Следующий() Цикл 
    Если Выборка.ПодтверждениеОПереносе = Истина Тогда
 
        СтрокаТабличнойЧасти = Товары.Добавить();
        СтрокаТабличнойЧасти.Примечание = Выборка.Примечание;
        СтрокаТабличнойЧасти.Номенклатура = Выборка.Номенклатура;
        СтрокаТабличнойЧасти.Количество = Выборка.Количество;
        СтрокаТабличнойЧасти.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
        СтрокаТабличнойЧасти.Коэффициент = Выборка.Коэффициент;
        СтрокаТабличнойЧасти.ОбщийВес = Выборка.ОбщийВес;
        СтрокаТабличнойЧасти.СоставМатериала = Выборка.СоставМатериала;
        СтрокаТабличнойЧасти.ДополнительныеПояснения = Выборка.ДополнительныеПояснения;
        СтрокаТабличнойЧасти.Работы = Выборка.Работы;
        СтрокаТабличнойЧасти.Запас = Выборка.Запас;
        СтрокаТабличнойЧасти.Запас = Выборка.ПодтверждениеОПереносе

    КонецЕсли;
КонецЦикла;

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
да уж, как не крутил а так не попробовал, все понятно, спасибо еще раз!


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3180
Последний ответ 21 Мар 2015, 20:24
от дфтын
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 223
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1046
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4474
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Заполнение формы на основании другой формы

Автор Саша АлдаевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 349
Последний ответ 11 Июл 2017, 00:11
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 192
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal