Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 08:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: этаформа.Текущийэлемент  (Прочитано 4957 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн wolf3d

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 7
  • КПД: 17%
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 8.1
платформа 8.0, конфа самописная
 мне необходимо чтобы если вводится неверное значение в код продавца, курсор возвращался на тоже поле (Полеввода4)
 у меня как ни плясал с бубном упорно переходит на след поле (Цена)
единственное что получилось сделать - это повесить код  этаформа.ТекущийЭлемент=элементыформы.ПолеВвода4;
на кнопку - тогда это работает, но мне необходимо чтобы срабатывало именно на полеввода4
 код и картинку прилагаю
Процедура ПолеВвода4ПриИзменении(Элемент)
флКодПрод=0;
вв=неопределено;
вв=справочники.Сотрудники.НайтиПоКоду(сокрлп(элементыформы.ПолеВвода4.Значение));
если пустаястрока(сокрлп(вв.наименование)) = истина тогда
  сигнал();
  сигнал();
  сигнал();
  сигнал();
  флКодПрод=1;
  элементыформы.Надпись20.Значение = "Нет такого продавца!!! Повторите ввод!!!";
иначе
  элементыформы.Надпись20.Значение = вв.наименование;
КонецЕсли;
если флКодПрод=1 тогда
  этаформа.ТекущийЭлемент=элементыформы.ПолеВвода4;
КонецЕсли;
КонецПроцедуры


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Полеввода4 - это код?
Добавлено: 10 Дек 2012, 16:48

Если я правильно понял, курсор не должен переходить на другое поле, если код не правильно заполнен. Попробуйте воспользоваться событием "Автоподбор"
Процедура ПолеВвода4АвтоПодбор(Элемент, Текст, ДанныеВыбора, Ожидание, СтандартнаяОбработка)
    Если Текст <> Код Тогда
        элементыформы.Надпись20.Значение = "Нет такого продавца!!! Повторите ввод!!!";
    КонецЕсли;
КонецПроцедуры

Последний раз редактировалось: Gunner; 10 Дек 2012, 16:48

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Это у вас форма чего?
Документа? Справочника?

Нельзя при записи проверить код на правильность и если что "ругнуться" и не дать записать?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Последний раз редактировалось: cska-fanat-kz; 11 Дек 2012, 09:59

Оффлайн wolf3d

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 7
  • КПД: 17%
  • Регистрация: 2011-01-22
  • Сайт: 
  • Профессия: Программист 8.1
Это у вас форма чего?Документа? Справочника?Нельзя при записи проверить код на правильность и если что "ругнуться" и не дать записать?
1.это форма отчета
2. так и сделал - продавцов устроило, ну и славно

так что тему можно закрывать)


Теги:
 

ТекущийЭлемент

Автор 1cwikiРаздел Синтаксис

Ответов: 0
Просмотров: 380
Последний ответ 07 Дек 2015, 01:45
от 1cwiki

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
135 Сообщений
AIFrame
63 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 434
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal