Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переменная не определена  (Прочитано 4857 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Snakey

  • *
  • Сообщений: 20
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-12-06
  • Сайт: 
  • Профессия: Консультант 1С
Голова едет кругом... Помогите плз. Ошибка:
{Справочник.Гаражи.МодульОбъекта(84,27)}: Переменная не определена (Организация)
      ТабДокумент = ПечатьПД4(<<?>>Организация); (Проверка: Толстый клиент (обычное приложение))



Функция ПечатьПД4(Организация) Экспорт
      
      Если Константы.СуммаКвитанции=0 Тогда
         Предупреждение("Не заполнена константа 'Сумма для квитанции'!");
         //Возврат
      КонецЕсли;
      ТекстЗаЧто=Открытие();
      ТабДокумент = Новый ТабличныйДокумент();
      ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Гаражи_ПД4";
      Макет       = ПолучитьМакет("ПД4");
      Шапка         = Макет.ПолучитьОбласть("Квит");
      //ШапкаТаблицы  = Макет.ПолучитьОбласть("ШапкаТаблицы");
      Запрос = Новый Запрос();
      Запрос.УстановитьПараметр("Организация",   Организация);
      НовыйОбъект = Справочники.Гаражи;
      ОписаниеОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация);
      //ВыбЭлемент=ЭтотОбъект.ВыбратьЭлемент;
      //Пока ВыбЭлемент <> Неопределено Цикл
         ОбластьМакета = Макет.ПолучитьОбласть("ЛицеваяСторона");
         ОбластьМакета.Параметры.НомерСчета=ОписаниеОрганизации.НомерСчета;
         ОбластьМакета.Параметры.БанковскиеРеквизиты=СокрЛП(ОписаниеОрганизации.БанкОрганизации)+" г. Москва Сбербанка России";
         ОбластьМакета.Параметры.КоррСчет=ОписаниеОрганизации.КоррСчет;
         ОбластьМакета.Параметры.Бик=ОписаниеОрганизации.БИК;
         ОбластьМакета.Параметры.НаименованиеПлатежа=СокрЛП(ЭтотОбъект.ВладелецГаража)+ТекстЗаЧто+" Бокс № "+СокрЛП(ЭтотОбъект.Код);
         ОбластьМакета.Параметры.ДатаОпл="        ";
         ОбластьМакета.Параметры.СуммаПлатежа=СокрЛП(Цел(Константы.СуммаКвитанции))+" руб. ";
         KKKw=СокрЛП((Константы.СуммаКвитанции-Цел(Константы.СуммаКвитанции))*100);
         ОбластьМакета.Параметры.ККК=KKKw;
         Если СтрДлина(KKKw)<2 Тогда
            Пока СтрДлина(KKKw)<2 Цикл
               KKKw="0"+KKKw;
            КонецЦикла;
         КонецЕсли;
         СуммаПлатежа=СуммаПлатежа+KKKw+" коп.";
         Перв=Перв+1;
         ТабДокумент.ВывестиСекцию("Квит");
         Если Перв=2 Тогда
            ТабДокумент.НоваяСтраница();
            Перв=0;
            //Прервать;
         КонецЕсли;
      //КонецЦикла;
      //ТабДокумент.ТолькоПросмотр(1);
      //ТабДокумент.Опции(0,0,0,0);
      //ТабДокумент.Показать("");
      Возврат ТабДокумент;
   КонецФункции
   
Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь, ФормаЭлемента = Неопределено) Экспорт
      // Получить экземпляр документа на печать
   Если ИмяМакета = "ПД4" Тогда
      ТабДокумент = ПечатьПД4(Организация);
   Иначе
      Сообщить("Ошибка получения дополнительной печатной формы объекта. Возможно форма была удалена", СтатусСообщения.Важное);
   КонецЕсли;
   УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, "Форма ПД4", НепосредственнаяПечать);
КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
переменная не определена "ОРГАНИЗАЦИЯ"

Где тут объявление переменной ОРГАНИЗАЦИЯ?
Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь, ФормаЭлемента = Неопределено) Экспорт
      // Получить экземпляр документа на печать
   Если ИмяМакета = "ПД4" Тогда
      ТабДокумент = ПечатьПД4(Организация);
   Иначе
      Сообщить("Ошибка получения дополнительной печатной формы объекта. Возможно форма была удалена", СтатусСообщения.Важное);
   КонецЕсли;
   УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, "Форма ПД4", НепосредственнаяПечать);
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
а еще должен ругаться тут
 ОписаниеОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация);

и тут
ОбластьМакета.Параметры.СуммаПлатежа=СокрЛП(Цел(Константы.СуммаКвитанции))+" руб. ";

и тут
KKKw=СокрЛП((Константы.СуммаКвитанции-Цел(Константы.СуммаКвитанции))*100);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6360
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Ошибка Процедура или функция с указанным именем не определена

Автор ser36Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2579
Последний ответ 26 Май 2015, 09:45
от cska-fanat-kz
Процедура или функция с указанным именем не определена (Записать)

Автор oo ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1883
Последний ответ 02 Фев 2017, 13:04
от oo oo
Процедура или функция с указанным именем не определена

Автор asd_123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5608
Последний ответ 24 Янв 2012, 16:07
от asd_123
Для каждого запроса, области макета новая переменная?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 831
Последний ответ 29 Июн 2016, 10:15
от Luzer1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 322
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal