Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 14:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проведение из управляемой формы  (Прочитано 1611 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн agusikdeon

  • ***
  • Сообщений: 111
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-01-14
  • Сайт: 
  • Профессия: Ученик 1С
конфа Автосервис(на основе УНФ 8.2)


вот код обработки





&НаКлиенте
Процедура установитьскидку(Команда)
а=Элементы.Поле3.ТекстРедактирования;
б=Элементы.Поле2.ТекстРедактирования;
в=Элементы.Поле4.ТекстРедактирования;
г=Элементы.Поле1.ТекстРедактирования;
ВыполнитьВыборкуНаСервере(а,б,в,г);

Сообщение=Новый СообщениеПользователю();
Сообщение.Текст="Скидки установленны";
Сообщение.Сообщить();
                       
КонецПроцедуры

&НаСервере
Процедура ВыполнитьВыборкуНаСервере(ДатаНач,ДатаОконч,Контрагент,Скидка) //Директива &НАСервере - выполняет перегрузку всей формы на сервер
   ДатаНач=ДатаНач+" 00:00:00";
   ДатаОконч=ДатаОконч+" 00:00:00";
    Запрос = Новый Запрос; //И так далее...
Запрос.Текст="ВЫБРАТЬ
             | асЗаказНаряд.Ссылка
             |ИЗ
             | Документ.асЗаказНаряд КАК асЗаказНаряд
             |ГДЕ
             | асЗаказНаряд.Контрагент = &Контрагент
             | И асЗаказНаряд.Дата МЕЖДУ &Дата1 И &Дата2";
Запрос.УстановитьПараметр("Контрагент",Справочники.Контрагенты.НайтиПоНаименованию(Контрагент)); //Объект - обработка объект
Запрос.УстановитьПараметр("Дата1",Дата(ДатаНач));
Запрос.УстановитьПараметр("Дата2",Дата(ДатаОконч));


Результат=Запрос.Выполнить().Выбрать();
ааа=Результат.Количество();
Пока Результат.Следующий() Цикл
 Орт=Результат.Ссылка.ПолучитьОбъект();

Для каждого товар из орт.работы Цикл
товар.ПроцентСкидкиНаценки=Число(Скидка);
Товар.Сумма=Товар.сумма-товар.сумма*Число(Скидка)/100;




КонецЦикла;
Орт.Записать(РежимЗаписиДокумента.Проведение);
КонецЦикла;
КонецПроцедуры
   


запускаю обработку. все проходит захожу в документ, там скидка стоит цена изменилась, но данные суммы в регистрах остались прежние, следовательно и на печатной форме тоже старые цены. как провести документ программно чтобы все поменялось? слышал что-то про то что нужно использовать функции ЗначениеВДанныеФормы и наоборот. но не пойму что и как.

Последний раз редактировалось: MuI_I_Ika; 06 Дек 2012, 18:45


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 285
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4812
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3407
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4984
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 582
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal