Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 окт 2021, 00:27

в расходной накладной,когда выводишь на печать,сумма пишется на русском языке.

Автор Сергей44, 19 дек 2009, 14:04

0 Пользователей и 1 гость просматривают эту тему.

Сергей44

Как изменить язык,что бы сумма писалась на украинском языке?

DDD

Прежде всего – какая у Вас конфигурация типовая или самописная?
Если типовая – то там уже всё сделано, необходимо в папку с базой положить файлы с прописью. Если эти файлы поместить в папку с программой (обычно это каталог programfiles\1cv77\Bin или programfiles\1cv77.adm\Bin).
Как именованы файлы:
первые три символа – международное название валюты, суффикс – язык, расширение SPL.
По содержимому это текстовые файлы. Пример прописи на украинском языке для гривны и названий месяцев в конце поста в Приложении.
Если база самописная, в которой не предусмотрена работа с национальными языками, кроме русского (он по умолчанию и прописан в платформе) – я расскажу поподробнее.
В типовых файлах прописи кроме месяцев есть еще и описание денежных единиц конкретной валюты на конкретном языке.
Вам понадобятся файлы прописи на украинском языке, и программно задать работу с конкретным языком оператором Прописть(ИмяФайлаПрописи). После этого все строки с буквенным форматированием (названия месяцев, суммы прописью и т.д.) будут выводиться на указанном в файле языке.
Например, Формат(ДатаДок, "ДДДММММГГГГ") выведет строку "18 Березня 2009 р."
В Глобальном модуле, чтоб не писать в каждом документе, определить процедуру, которая будет устанавливать язык для печатных форм. В типовых конфигурациях для этого используется процедура глУстПропись. Создайте её и Вы. В первом параметре передается валюта (гривня, рубли, доллары, евро и т.д.), во втором параметре язык литерой "р" для русского языка или "у" для украинского.
В справочнике Валюты определены реквизиты:
ФайлПрописиРус строка, для хранения имени файла (и пути) прописи на русском языке.
ФайлПрописиУкр строка, для хранения имени файла (и пути) прописи на украинском языке.
Процедура глУстПропись(Вал,Язык = "") Экспорт
Язык = Нрег(Язык);
Если Язык = "" Тогда
// из константы
Если Константа.ФормыНаУкраинском = Нет Тогда
Пропись(СокрЛП(Вал.ФайлПрописиРус));
Иначе
Пропись(СокрЛП(Вал.ФайлПрописиУкр));
КонецЕсли;
ИначеЕсли (Язык = "р") или (Язык = "русский") Тогда
Пропись(СокрЛП(Вал.ФайлПрописиРус));
ИначеЕсли (Язык = "у") или (Язык = "украинский") Тогда
Пропись(СокрЛП(Вал.ФайлПрописиУкр));
КонецЕсли;
КонецПроцедуры
Хотя в конкретном случае с одной валютой – гривной и выводом всех печатных форм на украинском языке достаточно будет текст из Приложения сохранить в файл uahukr.spl и положить этот файл в папку с базой. А в процедуре печати достаточно будет написать Пропись("uahukr.spl");
Пример:
Процедура Печать()
Пропись("uahukr.spl")
....
создание и заполнение печатной формы
....
Приложение:
{"Speller",
{"Money",
{"Гривня","Гривні","Гривень","копійка","копійки","копійок","F"}},
{"Numbers",
{"Один","Два","Три","Чотири","П'ять","Шість","Сім","Вісім","Дев'ять","Одна","Дві",
"Десять","Одинадцять","Дванадцять","Тринадцять","Чотирнадцять","П'ятнадцять","Шістнадцять","Сімнадцять","Вісімнадцять","Дев'ятнадцять",
"Двадцять","Тридцять","Сорок","П'ятдесят","Шістдесят","Сімдесят","Вісімдесят","Дев'яносто",
"Сто","Двісті","Триста","Чотириста","П'ятсот","Шістсот","Сімсот","Вісімсот","Дев'ятсот",
"Тисяча","Тисячі","Тисяч",
"Мільйон","Мільйона","Мільйонів",
"Мільярд","Мільярда","Мільярдів",
"Трильйон","Трильйона","Трильйонів",
"Нуль"}},
{"Date",
{"Січень","Лютий","Березень","Квітень","Травень","Червень","Липень","Серпень","Вересень","Жовтень","Листопад","Грудень",
"Січня","Лютого","Березня","Квітня","Травня","Червня","Липня","Серпня","Вересня","Жовтня","Листопада","Грудня",
"р.","Квартал"}},
{"DateRange",
{"Півріччя","Місяців"}},
{"WeekDay",
{"Понеділок","Вівторок","Середа","Четвер","П'ятниця","Субота","Неділя"}}
}



Теги:

Похожие темы (3)

Рейтинг@Mail.ru Rambler's Top100

Поиск