Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установка скидок для контрагента в бухгалтерии 2.0 8.2  (Прочитано 6705 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Доброго всем времени суток !


У меня такая проблема... если бы вы могли бы помочь или хотя бы подсказать с чего лучше начать было бы ооооочень хорошо ! =)



Суть в том что на фирме каждому контрагенту дают свою скидку.. и текучка кадров тоже... оставляет желать лучшего...



Хотелось бы сделать так что бы за каждым контрагентом была закреплена своя скидка... как есть ли возможность реализации данной функции в Бухгалтерии 8.2 ?



И если есть не могли подсказать с чего начать !

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:51


Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Я вижу решение данного вопроса так...

Новый реквезит в справочнике "Контрагенты" "Скидка" далее работа не посредственно с документом РТУ

Код как я понимаю должен быть такой

Если НЕ NULL
Тогда
Справочники.Контрагенты.Скидка
КонецЕсли
Вот ток куда и как его написать я пока не знаю !
Добавлено: 04 Дек 2012, 22:50

	Если
ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки
Тогда
ЭлементыФормы.Товары.Данные.СуммаСкидки = ЭлементыФормы.Контрагент.Значение.Скидка;
КонецЕсли;

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:51

Оффлайн mr.lefthander

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 2
  • КПД: 20%
  • Регистрация: 2012-02-03
  • Сайт: 
  • Профессия: Программист 1С
И если есть не могли подсказать с чего начать !
Есть много возможных вариантов решения задачи, но абсолютно точно это - не 5-10 строчек кода. Потребуется доработка конфигурации.

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:52

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Добавьте реквизит "скидка" в справочнике "контрагенты". Далее во всех документах, где исп. скидка, просто читайте значение по реквизиту "контрагент" и записывайте

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:52

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
Выскажу свое мнение. Считаю, что все-таки скидки лучше хранить в периодическом регистре сведений. Это удобно, если документы правятся задним числом.

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:53

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Хм.... все сделал но почему то скидка не перекидывается в документ ! :trhregerhg:




Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:53

Оффлайн Msoul

  • **
  • Сообщений: 74
  • РЕПУТАЦИЯ: 6
  • КПД: 8%
  • Регистрация: 2010-04-19
  • Сайт: 
А где код которым скидка перекидывается?

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:53

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Если *********************************************** <- :dfbsdfbsdf:
Тогда СуммаСкидки = ("(СуммаБезСкидки/100)*Скидка") <- Мне нужно что бы скидка выдавалась в поле СуммаСкидки
КонецЕсли;

Также сделал видимость в документе саму скидку... с данного показателя (в документе) и опираюсь на % скидки....

То есть с Контрагента скидка показывается в Документе РТУ, а уже далее я работаю с данной ссылкой в документе !

P.S. ребят я просто ток.... ток.... начал разбираться !

Добавлено: 26 Дек 2012, 17:01

Решил проблему данным образом !

Знаю что может быть и компакнее... но это мое решение если есть предложения лучше буду рад их увидеть !

Скидка по контрагентам

Справочник.Контрагенты

новый реквезит «СкидкаПоКонтрагенту»
Тип – Строка       Длина – 4

ФормаЭлемента – Новое поле ввода «Скидка»

Процедура ПриОткрытии()   

Если НЕ РольДоступна("Просмотр")
Тогда ЭлементыФормы.Скидка.РедактированиеТекста = ТолькоПросмотр=Истина
КонецЕсли;

Процедура СкидкаОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)
Если НЕ РольДоступна("Просмотр")
   Тогда ТолькоПросмотр=Истина
КонецЕсли;
КонецПроцедуры

Документы.РеализацияТоваровУслуг

Новый реквизит «Скидка»
Тип – Строка       Длина – 4

ТабличныеЧасти.Товары  реквезит «СуммаСкидки»
Тип – Число       Длина – 6 Точность - 2

ФормаДокумента – Новое поле ввода данные -«Скидка»

Процедура ПриОткрытии()
   
 Если Скидка<> Контрагент.СкидкаПоКонтрагенту 
Тогда Скидка = Контрагент.СкидкаПоКонтрагенту
КонецЕсли;

Процедура ОбновлениеОтображения()
Если Скидка<> Контрагент.СкидкаПоКонтрагенту 
Тогда Скидка = Контрагент.СкидкаПоКонтрагенту
КонецЕсли;

Процедура КонтрагентПриИзменении(Элемент)
   
   
Если Скидка<> Контрагент.СкидкаПоКонтрагенту 
Тогда Скидка = Контрагент.СкидкаПоКонтрагенту
КонецЕсли;

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;



Скидка по контрагентам

Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока)
   
   ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
   
   ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   
   ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
   ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыНоменклатураПриИзменении(Элемент)
   ЭлементыФормы.Товары.ТекущаяСтрока.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
   
    ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыЦенаПриИзменении(Элемент)
   
   Если ЭлементыФормы.Товары.ТекущиеДанные.Цена >=0
   Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
   КонецЕсли;


УБРАТЬ
Процедура ТоварыСкидкаПриИзменении(Элемент)
   
// Выполнить общие действия для всех документов при изменении Суммы.
ОбработкаТабличныхЧастей.ПриИзмененииСкидкиТабЧасти(ЭлементыФормы.Товары.ТекущиеДанные, ЭтотОбъект);

// Рассчитать реквизиты табличной части.
ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(ЭлементыФормы.Товары.ТекущиеДанные, ЭтотОбъект);
КонецПроцедуры

Процедура ТоварыСуммаСкидкиНачалоВыбора(Элемент, СтандартнаяОбработка)
   
 ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки = (ЭлементыФормы.Товары.СуммаБезскидки/100)*Скидка
КонецПроцедуры   

Добавлено: 27 Дек 2012, 13:13

Также в данную процедуру надо вставить данный код иначе СуммаНДС будет правильно просчитываться ток при повторном вводе цены !
Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

	Если ЭлементыФормы.Товары.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС20 
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = ЭлементыФормы.Товары.ТекущиеДанные.Сумма/5;
Иначе ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = ""
КонецЕсли;

Последний раз редактировалось: MuI_I_Ika; 27 Дек 2012, 13:54

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Если ЭлементыФормы.Товары.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС20 
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = ЭлементыФормы.Товары.ТекущиеДанные.Сумма/5;
Иначе ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = ""
КонецЕсли;
грамотнее будет так:

Если ЭлементыФормы.Товары.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС20 
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = (ЭлементыФормы.Товары.ТекущиеДанные.Сумма*ЭлементыФормы.Товары.ТекущиеДанные.СтавкаНДС)/100
Иначе ЭлементыФормы.Товары.ТекущиеДанные.СуммаНДС = ""
КонецЕсли;
Добавлено: 30 Дек 2012, 14:26

Сопсно  посидев помозговав.... пришел вот к чему:

Справочник.Контрагенты

новый реквезит «СкидкаПоКонтрагенту»
Тип – Строка       Длина – 4

ФормаЭлемента – Новое поле ввода «Скидка»

Процедура ПриОткрытии()	

Если НЕ РольДоступна("Просмотр")
Тогда ЭлементыФормы.Скидка.РедактированиеТекста = ТолькоПросмотр=Истина
КонецЕсли;

Документы.РеализацияТоваровУслуг

Новый реквизит «Скидка»
Тип – Строка       Длина – 4

ТабличныеЧасти.Товары  реквезит «СуммаСкидки»
Тип – Число       Длина – 6 Точность - 2

ФормаДокумента – Новое поле ввода данные -«Скидка»

Процедура ПриОткрытии()

Скидка = Контрагент.СкидкаПоКонтрагенту;

Процедура ОбновлениеОтображения()

Тогда Скидка = Контрагент.СкидкаПоКонтрагенту;

Процедура КонтрагентПриИзменении(Элемент)


ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;


Процедура ТоварыПриНачалеРедактирования(Элемент, НоваяСтрока)

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;

ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);


Процедура ТоварыНоменклатураПриИзменении(Элемент)

ЭлементыФормы.Товары.ТекущаяСтрока.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;

ЭлементыФормы.Товары.ТекущиеДанные.Сумма =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки-ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки);

Процедура ТоварыЦенаПриИзменении(Элемент)

Если ЭлементыФормы.Товары.ТекущиеДанные.Цена >=0
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаСкидки =(ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки/100)*Скидка;
КонецЕсли;


Если ЭлементыФормы.Товары.ТекущиеДанные.Цена >=0
Тогда ЭлементыФормы.Товары.ТекущиеДанные.СуммаБезСкидки= (ЭлементыФормы.Товары.ТекущиеДанные.Количество * ЭлементыФормы.Товары.ТекущиеДанные.Цена)
КонецЕсли;

Последний раз редактировалось: EritikWoW; 30 Дек 2012, 14:26


Теги:
 

Установка ориентации страницы "Ландшафт"

Автор summerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4680
Последний ответ 11 Янв 2011, 11:05
от summer
Внешняя обработка для документа "Установка цен номенклатуры"

Автор MArrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 4468
Последний ответ 05 Апр 2015, 08:21
от blackmoon89
Мои задачи (задачи исполнителя) в Бухгалтерии 2.x

Автор AlexandrITРаздел Пользователям "1С - Предприятие 8"

Ответов: 9
Просмотров: 4581
Последний ответ 04 Окт 2013, 13:57
от MuI_I_Ika
Установка цены продажи из документа "Поступление товаров и услуг" как?

Автор grandistokРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1780
Последний ответ 13 Май 2014, 16:34
от cska-fanat-kz
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 224
Последний ответ 18 Авг 2017, 11:57
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 135
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal