Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос к регистру сведений, не могу вытащить данные  (Прочитано 4573 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Надо вытащить из регистра сведений телефон контрагента. 
В регистре: Обьект-организация, Вид-телефон, адрес и т.д. контрагента, Представление-номер телефона, адрес и т.д.   Конфа УТ 10.3.
Запрос = Новый Запрос ( "ВЫБРАТЬ |    КонтактнаяИнформация.Представление |ИЗ |    РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация |ГДЕ |    КонтактнаяИнформация.Объект = &КонтактноеЛицо" ); Запрос.УстановитьПараметр("КонтактноеЛицо",КонтактноеЛицо); Результат=запрос.Выполнить().Выгрузить(); КТелефонЛогистика=Результат.ВыгрузитьКолонку("представление");


Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Помогите, а то у меня эта задача мертвым грузом повисла!

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Что именно не получается?

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо за внимание. Я сам сделал.
Интересовало что у меня не получается:
смотрите 1-ый вариант кода выше
2-й что получилось и заработало:
Запрос = Новый Запрос;
      Запрос.Текст = "ВЫБРАТЬ
                  |   КонтактнаяИнформация.Поле3
                  |ИЗ
                  |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация";
      Результат = Запрос.Выполнить();
      Выборка = Результат.Выбрать();
      Пока Выборка.Следующий() Цикл
         ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
      КонецЦикла;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
а где отбор по объекту?
где отбор по типу?

перебирается весь регистр чтобы вывести в макет последнее значение из Поле3!
жееееесть!
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
а где отбор по объекту?
где отбор по типу?

перебирается весь регистр чтобы вывести в макет последнее значение из Поле3!
жееееесть!
а как правильнее код выглядет будет?
Добавлено: 05 Дек 2012, 12:28

а где отбор по объекту?
где отбор по типу?

перебирается весь регистр чтобы вывести в макет последнее значение из Поле3!
жееееесть!
а как правильнее код выглядет будет?
И я еще добалю что значений параметров объект и тип у меня не задано. Теперь жду отредактированный код правильный. Спасибо.
Добавлено: 05 Дек 2012, 12:54

Сам сделал. Спасибо.
Запрос = Новый Запрос;
      Запрос.Текст = "ВЫБРАТЬ
                     |   КонтактнаяИнформация.Поле3
                     |ИЗ
                     |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
                  |ГДЕ
                  |    КонтактнаяИнформация.Объект = &Объект
                  |И
                     |    КонтактнаяИнформация.Тип = &Тип";
      Запрос.УстановитьПараметр("Объект", СсылкаНаОбъект.Ответственный);             
      Запрос.УстановитьПараметр("Тип", Перечисления.ТипыКонтактнойИнформации.Телефон);
      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
         ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
      КонецЦикла;

Последний раз редактировалось: djvjv; 05 Дек 2012, 12:54

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Пока Выборка.Следующий() Цикл
         ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
      КонецЦикла;
лучше будет
Если Выборка.Следующий() Тогда
     ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
КонецЕсли;
skype: slin-dev

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Пока Выборка.Следующий() Цикл
         ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
      КонецЦикла;
лучше будет
Если Выборка.Следующий() Тогда
     ОбластьМакета.Параметры.Телефон = Выборка.Поле3;
КонецЕсли;
В моем случае просто всегда телефон будет. Моя база самописная, делаю на основе УТ 10.3. Так сказать учусь азам программирования.


Теги:
 

Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2999
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 985
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 689
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 16557
Последний ответ 02 Сен 2011, 01:14
от bolobol
Ошибка "Построенный запрос к СУБД использует слишком много таблиц"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 8058
Последний ответ 03 Дек 2012, 14:04
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 136
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal