Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ТиС 7.7 узнать город Контрагента  (Прочитано 2051 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lionzi

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-15
  • Сайт: 
Подскажте пожалуйста.

Каким образом можно получить значение города из фактического адреса контрагента?
чтой-то я запутался в структуре...

Заранее благодарен.


Оффлайн Lionzi

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-15
  • Сайт: 
Пока сделал циклом, кажется это не оптимально...

Функция ПолучитьГород(Адрес)   

Адрес = сокрлп(Адрес);
НомерЗапятой = 0;

Для Сч = 1 По СтрДлина(Адрес) Цикл
   ТекСимвол = Сред(Адрес,Сч,1);
   Если Тексимвол = "," Тогда         
      Если НомерЗапятой < 3 Тогда
         НомерЗапятой = НомерЗапятой + 1;
      Иначе
         Адрес1 = Сред(Адрес,Сч+1);
         Прервать;
      КонецЕсли;
   КонецЕсли;
КонецЦикла;                 

Для Ст = 1 По СтрДлина(Адрес1) Цикл
   ТекСимвол = Сред(Адрес1,Ст,1);
   Если Тексимвол = "," Тогда         
      Город = Лев(Адрес1,Ст-1);
      Если сокрлп(Город) = "" Тогда
         Адрес2 = Сред(Адрес1,Ст+1);
         сообщить(Адрес2);
         Для Ск = 1 По СтрДлина(Адрес2) Цикл
            ТекСимвол = Сред(Адрес2,Ск,1);
            Если Тексимвол = "," Тогда         
               Город = Лев(Адрес2,Ск-1);
               Прервать;
            КонецЕсли;
         КонецЦикла;   
      КонецЕсли;         
      Прервать;
   КонецЕсли;
КонецЦикла;                     

Возврат Город;
КонецФункции


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 333
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal