Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 окт 2021, 00:02

ТиС 7.7 узнать город Контрагента

Автор Lionzi, 15 дек 2009, 12:51

0 Пользователей и 1 гость просматривают эту тему.

Lionzi

Подскажте пожалуйста.

Каким образом можно получить значение города из фактического адреса контрагента?
чтой-то я запутался в структуре...

Заранее благодарен.

Lionzi

Пока сделал циклом, кажется это не оптимально...

Функция ПолучитьГород(Адрес)   

Адрес = сокрлп(Адрес);
НомерЗапятой = 0;

Для Сч = 1 По СтрДлина(Адрес) Цикл
   ТекСимвол = Сред(Адрес,Сч,1);
   Если Тексимвол = "," Тогда         
      Если НомерЗапятой < 3 Тогда
         НомерЗапятой = НомерЗапятой + 1;
      Иначе
         Адрес1 = Сред(Адрес,Сч+1);
         Прервать;
      КонецЕсли;
   КонецЕсли;
КонецЦикла;                 

Для Ст = 1 По СтрДлина(Адрес1) Цикл
   ТекСимвол = Сред(Адрес1,Ст,1);
   Если Тексимвол = "," Тогда         
      Город = Лев(Адрес1,Ст-1);
      Если сокрлп(Город) = "" Тогда
         Адрес2 = Сред(Адрес1,Ст+1);
         сообщить(Адрес2);
         Для Ск = 1 По СтрДлина(Адрес2) Цикл
            ТекСимвол = Сред(Адрес2,Ск,1);
            Если Тексимвол = "," Тогда         
               Город = Лев(Адрес2,Ск-1);
               Прервать;
            КонецЕсли;
         КонецЦикла;   
      КонецЕсли;         
      Прервать;
   КонецЕсли;
КонецЦикла;                     

Возврат Город;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск