Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Июн 2021, 03:02
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Заполнение двух форм сразу  (Прочитано 2297 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Регистрация: 2009-11-03
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Профессия: Бухгалтер
Как реализовать заполнение возможных значений поля выбора «ОбрабатываемаяТабличнаяЧасть» при заполнении поля ввода «ОбрабатываемыйДокумент»? При этом,в качестве данных – ОбрабатываемаяТабличнаяЧасть (тип  – Строка)


Оффлайн Buh777

  • *
  • Регистрация: 2009-11-19
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Профессия: Бухгалтер
через строку будет немного сложнее. лучше было бы списком, но есчли условие требует+)
Процедура ОбрабатываемыйДокументПриИзменении(Элемент)

СписокВыбора = ЭлементыФормы.ОбрабатываемаяТабличнаяЧасть.СписокВыбора;
СписокВыбора.Очистить();

Если Элемент.Значение <> Неопределено И Не(Элемент.Значение.Пустая()) Тогда
ТабличныеЧасти = Элемент.Значение.Метаданные().ТабличныеЧасти;

Для Каждого ТабличнаяЧасть из ТабличныеЧасти Цикл
СписокВыбора.Добавить(ТабличнаяЧасть);

КонецЦикла;

КонецЕсли;

КонецПроцедуры

Добавлю еще обработчик отчистки
Процедура ОбрабатываемыйДокументОчистка(Элемент, СтандартнаяОбработка)

ОбрабатываемаяТабличнаяЧасть = "";

КонецПроцедуры


Теги:
 

Заполнение табличной части документа, 1С 8.2, управляемое приложение

Автор ChychelkoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 8570
Последний ответ 23 Мар 2011, 15:58
от cska-fanat-kz
Создание и заполнение массива из справочника

Автор Дмитрий КотинскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 344
Последний ответ 06 Июл 2020, 13:40
от LexaK
Заполнение Макета

Автор adidaslerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6789
Последний ответ 11 Мар 2013, 20:41
от adidasler
Заполнение табличной части из excel при несовпадающих наименованиях.

Автор AntimolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 443
Последний ответ 13 Мая 2019, 05:11
от AIFrame
1с 8.3 БСО Заполнение подразделения в авансовом отчете

Автор АннаКРРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 5259
Последний ответ 19 Авг 2015, 13:01
от АннаКР

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
84 Сообщений
LexaK
64 Сообщений
antoneus antoneus
30 Сообщений
Ивашка
27 Сообщений
KATERINA 861
24 Сообщений
neek666
22 Сообщений
alexandr_ll
19 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
MiThO
8 Сообщений

* Кто онлайн

  • Точка Гостей: 89
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск