Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 12:24

Заполнение двух форм сразу

Автор ППП, 11 дек 2009, 09:54

0 Пользователей и 1 гость просматривают эту тему.

ППП

Как реализовать заполнение возможных значений поля выбора «ОбрабатываемаяТабличнаяЧасть» при заполнении поля ввода «ОбрабатываемыйДокумент»? При этом,в качестве данных – ОбрабатываемаяТабличнаяЧасть (тип  – Строка)
smo

Buh777

через строку будет немного сложнее. лучше было бы списком, но есчли условие требует+)
Процедура ОбрабатываемыйДокументПриИзменении(Элемент)

СписокВыбора = ЭлементыФормы.ОбрабатываемаяТабличнаяЧасть.СписокВыбора;
СписокВыбора.Очистить();

Если Элемент.Значение <> Неопределено И Не(Элемент.Значение.Пустая()) Тогда
ТабличныеЧасти = Элемент.Значение.Метаданные().ТабличныеЧасти;

Для Каждого ТабличнаяЧасть из ТабличныеЧасти Цикл
СписокВыбора.Добавить(ТабличнаяЧасть);

КонецЦикла;

КонецЕсли;

КонецПроцедуры


Добавлю еще обработчик отчистки
Процедура ОбрабатываемыйДокументОчистка(Элемент, СтандартнаяОбработка)

ОбрабатываемаяТабличнаяЧасть = "";

КонецПроцедуры

smo

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск