Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Окт 2018, 20:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение двух форм сразу  (Прочитано 1868 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Регистрация: 2009-11-03
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Как реализовать заполнение возможных значений поля выбора «ОбрабатываемаяТабличнаяЧасть» при заполнении поля ввода «ОбрабатываемыйДокумент»? При этом,в качестве данных – ОбрабатываемаяТабличнаяЧасть (тип  – Строка)


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
через строку будет немного сложнее. лучше было бы списком, но есчли условие требует+)
Процедура ОбрабатываемыйДокументПриИзменении(Элемент)

СписокВыбора = ЭлементыФормы.ОбрабатываемаяТабличнаяЧасть.СписокВыбора;
СписокВыбора.Очистить();

Если Элемент.Значение <> Неопределено И Не(Элемент.Значение.Пустая()) Тогда
ТабличныеЧасти = Элемент.Значение.Метаданные().ТабличныеЧасти;

Для Каждого ТабличнаяЧасть из ТабличныеЧасти Цикл
СписокВыбора.Добавить(ТабличнаяЧасть);

КонецЦикла;

КонецЕсли;

КонецПроцедуры

Добавлю еще обработчик отчистки
Процедура ОбрабатываемыйДокументОчистка(Элемент, СтандартнаяОбработка)

ОбрабатываемаяТабличнаяЧасть = "";

КонецПроцедуры


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 8876
Последний ответ 16 Авг 2012, 21:50
от Will
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2933
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 18036
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5009
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1622
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
71 Сообщений
MuI_I_Ika MuI_I_Ika
48 Сообщений
wise wise
38 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
byte777
37 Сообщений
LexaK
36 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 258
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal