Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 15:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор по спискам???  (Прочитано 1663 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн For

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Как организовать выбор документов для открытия из нескольких списков?


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер

данную таблицу можно выполнить следующим способом:
СписокДокументов = Новый СписокЗначений();

Док = Метаданные.Документы;

СписокДокументов.Добавить(Док.ПлатежноеПоручениеИсходящее             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеПоручениеВходящее             , , Ложь);
СписокДокументов.Добавить(Док.АккредитивПереданный             , , Ложь);
СписокДокументов.Добавить(Док.АккредитивПолученный             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеВыставленное             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеПолученное             , , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПереданное             , , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПолученное             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерСписаниеДенежныхСредств , , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерПоступлениеДенежныхСредств , , Ложь);

Если СписокДокументов.ОтметитьЭлементы("Укажите, какие списки документов открыть") Тогда

Для Каждого НазваниеДокумента из СписокДокументов Цикл

Если НазваниеДокумента.Пометка Тогда
ФормаСписка = Документы[НазваниеДокумента.Значение.Имя].ПолучитьФормуСписка();
ФормаСписка.Открыть();

КонецЕсли;
 
 КонецЦикла;

КонецЕсли;

Если, установив требуемые пометки, пользователь нажмет ОК, открываем цикл перебора элементов СписокДокуменов


Теги:
 

выбор параметра "Склад" в отчёте.

Автор The KAINРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 819
Последний ответ 22 Июн 2016, 08:11
от The KAIN
Как записать в поле ввода "Единица Измерения", которое заполняется через выбор из формы.

Автор Ivan94Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 288
Последний ответ 12 Окт 2017, 14:30
от Ivan94
Выбор элементов из ТЧ одного документа для переноса в ТЧ другого документа

Автор Никита ВикторовичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 100
Последний ответ 01 Дек 2017, 19:29
от Никита Викторович
Значение параметра "ВыбраннаяСтрока" в событии Выбор Табличного поля.

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7655
Последний ответ 09 Дек 2013, 15:03
от Katish
фильтр в табличной части документа на выбор значений пользователем из справочника по условию

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 297
Последний ответ 20 Июл 2017, 16:33
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 266
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal