Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 22:13

Выбор по спискам???

Автор For, 10 дек 2009, 15:21

0 Пользователей и 1 гость просматривают эту тему.

For

Как организовать выбор документов для открытия из нескольких списков?
smo

Buh777


данную таблицу можно выполнить следующим способом:
СписокДокументов = Новый СписокЗначений();

Док = Метаданные.Документы;

СписокДокументов.Добавить(Док.ПлатежноеПоручениеИсходящее             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеПоручениеВходящее             , , Ложь);
СписокДокументов.Добавить(Док.АккредитивПереданный             , , Ложь);
СписокДокументов.Добавить(Док.АккредитивПолученный             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеВыставленное             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежноеТребованиеПолученное             , , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПереданное             , , Ложь);
СписокДокументов.Добавить(Док.ИнкассовоеПоручениеПолученное             , , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерСписаниеДенежныхСредств , , Ложь);
СписокДокументов.Добавить(Док.ПлатежныйОрдерПоступлениеДенежныхСредств , , Ложь);

Если СписокДокументов.ОтметитьЭлементы("Укажите, какие списки документов открыть") Тогда

Для Каждого НазваниеДокумента из СписокДокументов Цикл

Если НазваниеДокумента.Пометка Тогда
ФормаСписка = Документы[НазваниеДокумента.Значение.Имя].ПолучитьФормуСписка();
ФормаСписка.Открыть();

КонецЕсли;

КонецЦикла;

КонецЕсли;


Если, установив требуемые пометки, пользователь нажмет ОК, открываем цикл перебора элементов СписокДокуменов
smo

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск