Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 окт 2021, 22:24

Остатки с писке номенклутары

Автор For, 10 дек 2009, 15:19

0 Пользователей и 1 гость просматривают эту тему.

For

Как вывести остатки на складах в списке номенклатуры с добавлением еще одной колонки :dfbsdfbsdf:
smo

Buh777

Цитата: For от 10 дек 2009, 15:19
Как вывести остатки на складах в списке номенклатуры с добавлением еще одной колонки :dfbsdfbsdf:
Вывод остатков из номенклатуры:
Процедура СписокНоменклатураПриПолученииДанных(Элемент, ОформленияСтрок)

Запрос = Новый Запрос("ВЫБРАТЬ
| ТоварыНаСкладахОстатки.КоличествоОстаток КАК Остаток,
| ТоварыНаСкладахОстатки.Номенклатура.Ссылка КАК Товар
|ИЗ
| РегистрНакопления.ТоварыНаСкладах.Остатки( , Номенклатура В (&МассивТоваров))
| КАК ТоварыНаСкладахОстатки");

МассивНоменклатуры = Новый Массив;   // для передачи в параметр запроса
Соответствие = Новый Соответствие; // для заполнения остатков в строках
// табличного поля

Для Каждого Строка из ОформленияСтрок Цикл
МассивНоменклатуры.Добавить(Строка.ДанныеСтроки.Ссылка);
Соответствие.Вставить(Строка.ДанныеСтроки.Ссылка, Строка);
КонецЦикла;

Запрос.УстановитьПараметр("МассивТоваров", МассивНоменклатуры);

Выборка = Запрос.Выполнить().Выбрать();

// Вывести остаток в строку, найденную в соответствии по номенклатуре из запроса.
Пока Выборка.Следующий() Цикл
Соответствие.Получить(Выборка.Товар.Ссылка).Ячейки.Остаток.Значение = Выборка.Остаток;
КонецЦикла;

КонецПроцедуры


В параметре ОформленияСтрок обработчика этого события передается коллекция оформлений строк, которые были выведены в табличное поле,это позволит получить все остатки один запросом
smo

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск