Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Сен 2020, 21:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перетаскивание между элементами управления  (Прочитано 8873 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн For

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Как реализовать возможность заполнения таблицы документа номенклатурными позициями, используя механизм перетаскивания т.е. использовать drag and drop


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Как реализовать возможность заполнения таблицы документа номенклатурными позициями, используя механизм перетаскивания т.е. использовать drag and drop

Сначала определим реквизит формы СправочникСписок (тип СправочникСписок.Номенклатура). Далее вставим элемент управления ТабличноеПоле и через свойство Данные свяжем его с созданным реквизитом. Далее через обработчик события
Процедура НоменклатураНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)

// Получить значение, переданное системой.
Значение = ПараметрыПеретаскивания.Значение;

// В любом случае значением будет массив.
МассивЗначений = Новый Массив;

// Если перетаскивается группа, то в массив записываем входящие в нее элементы.
Если Значение.ЭтоГруппа Тогда
Выборка = Справочники.Номенклатура.Выбрать(Значение);

Пока Выборка.Следующий() Цикл

Если Не Выборка.ЭтоГруппа Тогда
МассивЗначений.Добавить(Выборка.Ссылка);

КонецЕсли;

КонецЦикла;

Иначе
МассивЗначений.Добавить(Значение);

КонецЕсли;

// Заполненный массив записываем в параметры.
ПараметрыПеретаскивания.Значение = МассивЗначений;

КонецПроцедуры


Теги:
 

Обмен данными между 1С УТ (базовая) 8.2 редакция 10.3 и Розница (базовая) редакция 1.0

Автор Андрей ОлимпиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 8349
Последний ответ 17 Мар 2015, 20:16
от дфтын
Обмен между типовой и не типовой конфигурацией.

Автор Maestro90Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4668
Последний ответ 18 Сен 2012, 13:05
от Dethmontt
Различия между Подразделениями и Подразделениями организаций.

Автор EscaladasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7675
Последний ответ 26 Авг 2014, 13:18
от Escaladas
Обмен РИБ, обмен данными между организациями

Автор Azamat FaizovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2042
Последний ответ 18 Сен 2014, 11:48
от Azamat Faizov
обмен данными между 1с Розница и 1с Розница

Автор maksdemonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 4586
Последний ответ 23 Мар 2015, 13:53
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
30 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 248
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal