Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 окт 2021, 16:15

Перетаскивание между элементами управления

Автор For, 10 дек 2009, 15:17

0 Пользователей и 1 гость просматривают эту тему.

For

Как реализовать возможность заполнения таблицы документа номенклатурными позициями, используя механизм перетаскивания т.е. использовать drag and drop
smo

Buh777

Цитата: For от 10 дек 2009, 15:17
Как реализовать возможность заполнения таблицы документа номенклатурными позициями, используя механизм перетаскивания т.е. использовать drag and drop

Сначала определим реквизит формы СправочникСписок (тип СправочникСписок.Номенклатура). Далее вставим элемент управления ТабличноеПоле и через свойство Данные свяжем его с созданным реквизитом. Далее через обработчик события
Процедура НоменклатураНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка)

// Получить значение, переданное системой.
Значение = ПараметрыПеретаскивания.Значение;

// В любом случае значением будет массив.
МассивЗначений = Новый Массив;

// Если перетаскивается группа, то в массив записываем входящие в нее элементы.
Если Значение.ЭтоГруппа Тогда
Выборка = Справочники.Номенклатура.Выбрать(Значение);

Пока Выборка.Следующий() Цикл

Если Не Выборка.ЭтоГруппа Тогда
МассивЗначений.Добавить(Выборка.Ссылка);

КонецЕсли;

КонецЦикла;

Иначе
МассивЗначений.Добавить(Значение);

КонецЕсли;

// Заполненный массив записываем в параметры.
ПараметрыПеретаскивания.Значение = МассивЗначений;

КонецПроцедуры

smo

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск