Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Сен 2020, 01:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Печать Платежку на Азербайджанском языке  (Прочитано 9937 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sanan Celilli

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-10
  • Сайт: 
  • Профессия: Программист 7.7
Каким образом можно получит цифры прописью на азербайджанском языке ? Благодарю заранее!


Оффлайн Admin

  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Только в этом месте (документе) должен быть азербайджанский язык?
Подпись

Оффлайн Sanan Celilli

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-10
  • Сайт: 
  • Профессия: Программист 7.7
Я задаю формат
 ФорматСтрока  = "Л=az_Latn; ДП=Ложь";
А печатаеться на английском ?

Оффлайн Admin

  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Нет. Так не получиться.

Смотрите продцедуру перевода цифр в цифры прописью. Там прописано какой цифре какое текстовое значение и склонения. И в зависимости от того везде вам надо на азербайджанский переводить или только в платежках - правьте.

А  "ФорматСтрока  = "Л=az_Latn; ДП=Ложь";" это не переводчик.
Подпись

Оффлайн Sanan Celilli

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-10
  • Сайт: 
  • Профессия: Программист 7.7
Спасибо за совет. Дело в том, что я не знаю где искать продцедуру перевода цифр в цифры прописью. Если укажете место нахождение, то буду очень благодарен!

Оффлайн Admin

  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Вы в этой функции меняли ФорматСтрока  = "Л=ru_RU; ДП=Ложь"; ?


Функция ФорматироватьСуммуПрописи(СуммаДок,СуммаБезКопеек)

Результат     = СуммаДок;
ЦелаяЧасть    = Цел(СуммаДок);
ФорматСтрока  = "Л=ru_RU; ДП=Ложь";
ПарамПредмета = СчетОрганизации.ВалютаДенежныхСредств.ПараметрыПрописиНаРусском;

Если (Результат - ЦелаяЧасть) = 0 Тогда
Если СуммаБезКопеек Тогда
Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
Результат = Лев(Результат,Найти(Результат,"0")-1);
Иначе
Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
КонецЕсли;
Иначе
Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
КонецЕсли;

Возврат Результат;

КонецФункции // ФорматироватьСуммуПрописи()

Вот обратите внимание на

Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);

Подпись

Последний раз редактировалось: DDD; 15 Дек 2009, 14:53

Оффлайн Sanan Celilli

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-10
  • Сайт: 
  • Профессия: Программист 7.7
Да именно в этом месте я вставил ФорматСтрока  = "Л=az_Latn; ДП=Ложь";
В результате печатаеться английский текст прописи !!!

Оффлайн Admin

  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Азербайджанский язык не знаю, приведу пример с польским языком. По аналогии не сложно сдедать.

Замените в этой функции в трех местах

Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);

на

Результат =  ЧислоПрописью(Результат, "L=pl_PL;SN=true;FN=true;FS=true", "złoty, złote, złotych, m, grosz, grosze, groszy, m, 2");

Для польского это будет работать.

Вам надо поменять соответственно для азербайджанского Л=az_Latn и текст в кавычках для склонения валюты "złoty, złote, złotych, m, grosz, grosze, groszy"
Подпись

Оффлайн Sanan Celilli

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-12-10
  • Сайт: 
  • Профессия: Программист 7.7
Это всё понятно. Я спрашиваю про цифр, например 1000 = Одна тысяча, 225 = Двесто двадцат пять и т.д.

Оффлайн Admin

  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 38
  • КПД: 15%
  • Регистрация: 2008-07-10
  • Сайт: forum-1c.ru
  • Профессия: Программист 8.1
Так цифры у вас при этом тоже переведуться.
Вот замените целиком функцию на эту, с польским вариантом:

Функция ФорматироватьСуммуПрописи(СуммаДок,СуммаБезКопеек)

Результат     = СуммаДок;
ЦелаяЧасть    = Цел(СуммаДок);


ФорматСтрока  = "Л=ru_RU; ДП=Ложь";
ПарамПредмета = СчетОрганизации.ВалютаДенежныхСредств.ПараметрыПрописиНаРусском;

Если (Результат - ЦелаяЧасть) = 0 Тогда
Если СуммаБезКопеек Тогда
//Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
   Результат =  ЧислоПрописью(Результат, "L=pl_PL;SN=true;FN=true;FS=true", "złoty, złote, złotych, m, grosz, grosze, groszy, m, 2");

Результат = Лев(Результат,Найти(Результат,"0")-1);
Иначе
//Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
                   Результат =  ЧислоПрописью(Результат, "L=pl_PL;SN=true;FN=true;FS=true", "złoty, złote, złotych, m, grosz, grosze, groszy, m, 2");

КонецЕсли;
Иначе
//Результат = ЧислоПрописью(Результат,ФорматСтрока,ПарамПредмета);
                Результат =  ЧислоПрописью(Результат, "L=pl_PL;SN=true;FN=true;FS=true", "złoty, złote, złotych, m, grosz, grosze, groszy, m, 2");

КонецЕсли;

Возврат Результат;

КонецФункции // ФорматироватьСуммуПрописи()

После этого в платежку посмотрите, в графе Сумма прописью будет написано по польски:

Trzysta dziesięć tysięcy złotych zero groszy

(310000 - сумма платежки)

Все работает. Вам только во всех 3х местах надо еще поменять L=pl_PL;SN=true;FN=true;FS=true   на   L=az_Latn;SN=true;FN=true;FS=true
(это для цифр)

и самому написать и заменить перевод "złoty, złote, złotych, m, grosz, grosze, groszy, m, 2"
(это для наименования валюты) Валюта у вас какая будет?
Подпись


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 193
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal