Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Сен 2020, 11:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цвет фона ячейки  (Прочитано 13211 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grad

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Как поменять цвет фона ячейки таблдицы в зависимости от значения, которое в нее выводится?


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Re: Цвет фона ячейки
« Ответ #1: 10 Дек 2009, 10:27 »
Для этого следует использовать  обработчик события При получении данных() табличного поля. Сначала следует выделение ячеек табличного поля:
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение;
 
Если ЗначениеЯчейкиОстаток <> Неопределено Тогда
 
Если ЗначениеЯчейкиОстаток < 10 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;
 
ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры

!Цвет назначаем, подбирая его из системного набора значений WebЦвета.



Теги:
 

Заполнение ячейки "Объект"

Автор 007_11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 457
Последний ответ 26 Дек 2018, 15:44
от alex0402
Ячейки в документе "Пересчет товаров"

Автор RickRockРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1675
Последний ответ 09 Июн 2016, 10:21
от Rasty
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 6015
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Форматирование ячейки типа "Шаблон" в макете табличного документа

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 24780
Последний ответ 11 Апр 2012, 11:13
от cska-fanat-kz
1С 8.2 При изменении ячейки табличного поля обновить данные в регистре сведений

Автор drugoi_mirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 26446
Последний ответ 30 Мар 2012, 14:43
от drugoi_mir

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
oooo800
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 594
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal