Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цвет фона ячейки  (Прочитано 9904 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grad

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Как поменять цвет фона ячейки таблдицы в зависимости от значения, которое в нее выводится?


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Re: Цвет фона ячейки
« Ответ #1: 10 Дек 2009, 10:27 »
Для этого следует использовать  обработчик события При получении данных() табличного поля. Сначала следует выделение ячеек табличного поля:
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение;
 
Если ЗначениеЯчейкиОстаток <> Неопределено Тогда
 
Если ЗначениеЯчейкиОстаток < 10 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;
 
ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры

!Цвет назначаем, подбирая его из системного набора значений WebЦвета.



Теги:
 

Ячейки в документе "Пересчет товаров"

Автор RickRockРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 756
Последний ответ 09 Июн 2016, 10:21
от Rasty
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 2995
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Форматирование ячейки типа "Шаблон" в макете табличного документа

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 19387
Последний ответ 11 Апр 2012, 11:13
от cska-fanat-kz
1С 8.2 При изменении ячейки табличного поля обновить данные в регистре сведений

Автор drugoi_mirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 19420
Последний ответ 30 Мар 2012, 14:43
от drugoi_mir
Что значит пунктир в макетах? И как изменить ширину ячейки в одной строк?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7110
Последний ответ 19 Апр 2012, 12:05
от evialen

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 336
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal