Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 окт 2021, 15:39

Цвет фона ячейки

Автор Grad, 10 дек 2009, 10:18

0 Пользователей и 1 гость просматривают эту тему.

Grad

Как поменять цвет фона ячейки таблдицы в зависимости от значения, которое в нее выводится?

Никитина

Для этого следует использовать  обработчик события При получении данных() табличного поля. Сначала следует выделение ячеек табличного поля:
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)

Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение;

Если ЗначениеЯчейкиОстаток <> Неопределено Тогда

Если ЗначениеЯчейкиОстаток < 10 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;

ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;

КонецЕсли;

КонецЕсли;

КонецЦикла;

КонецПроцедуры


!Цвет назначаем, подбирая его из системного набора значений WebЦвета.


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск