Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 07:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть справочник сразу с группой  (Прочитано 2688 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grad

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Как обеспечить, чтобы для выбора значения покупателя в расходной накладной справочник «Контрагенты» открывался сразу с открытой группой «Покупатели», т.к. нам необходимо особым образом открыть форму выбора именно из формы документа,


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Обработчик события начала выбора выглядит так:
Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)
 
 Если Элемент.Значение.Пустая() Тогда
СтандартнаяОбработка = Ложь;

ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);

ФормаВыбора.ВыборПокупателя = Истина;

ФормаВыбора.Открыть();

 КонецЕсли;

КонецПроцедуры


И само открытие группы в форме справочника,Этот код как основа, это не является обязательным для выполнения, есть и другие выходы
Если ВыборПокупателя Тогда 
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;

КонецЕсли;



Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
176 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
41 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal