Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 окт 2021, 22:53

Открыть справочник сразу с группой

Автор Grad, 10 дек 2009, 10:17

0 Пользователей и 1 гость просматривают эту тему.

Grad

Как обеспечить, чтобы для выбора значения покупателя в расходной накладной справочник «Контрагенты» открывался сразу с открытой группой «Покупатели», т.к. нам необходимо особым образом открыть форму выбора именно из формы документа,

Никитина

Обработчик события начала выбора выглядит так:
Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)

Если Элемент.Значение.Пустая() Тогда
СтандартнаяОбработка = Ложь;

ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);

ФормаВыбора.ВыборПокупателя = Истина;

ФормаВыбора.Открыть();

КонецЕсли;

КонецПроцедуры



И само открытие группы в форме справочника,Этот код как основа, это не является обязательным для выполнения, есть и другие выходы
Если ВыборПокупателя Тогда
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;

КонецЕсли;



Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск