Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2019, 06:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть справочник сразу с группой  (Прочитано 3162 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Grad

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Как обеспечить, чтобы для выбора значения покупателя в расходной накладной справочник «Контрагенты» открывался сразу с открытой группой «Покупатели», т.к. нам необходимо особым образом открыть форму выбора именно из формы документа,


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Обработчик события начала выбора выглядит так:
Процедура КонтрагентНачалоВыбора(Элемент, СтандартнаяОбработка)
 
 Если Элемент.Значение.Пустая() Тогда
СтандартнаяОбработка = Ложь;

ФормаВыбора = Справочники.Контрагенты.ПолучитьФормуВыбора( , Элемент);

ФормаВыбора.ВыборПокупателя = Истина;

ФормаВыбора.Открыть();

 КонецЕсли;

КонецПроцедуры


И само открытие группы в форме справочника,Этот код как основа, это не является обязательным для выполнения, есть и другие выходы
Если ВыборПокупателя Тогда 
ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Истина;
ЭлементыФормы.СправочникСписок.ТекущийРодитель = Справочники.Контрагенты.Покупатели;

КонецЕсли;



Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
60 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
56 Сообщений
DmitriyF DmitriyF
53 Сообщений
alexandr_ll
37 Сообщений
AIFrame AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
alex0402
23 Сообщений
antoneus antoneus
20 Сообщений
isacnew21
16 Сообщений
pavl_vs
15 Сообщений

* Кто онлайн

  • Точка Гостей: 307
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal