Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Сен 2020, 22:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по бизнес -процессу  (Прочитано 2738 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Леонид

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-03
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Имеется бизнес-процесс,, в котором количество последовательных этапов определяется индивидуально на момент старта экземпляра процесса. Необходимоопределить этот процесс на старте по запросу. При этом процесс может  иметь очень долгий период (с утра и до вечера)


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
При использовании таких реквезитов адресации:
Пользователь (ссылка на справочник Пользователи);
Подразделение.
Считается что в регистре сведений, отвечающем за адресацию, соответствующие сведения измерения существуют.
Реквизиты задачи:
ДатаВыполнения (время выполнения задачи);
Исполнитель (ссылка на справочник пользователей системы);
Склад (ссылка на справочник складов)

обрабтка перед выполнением
Процедура ПередВыполнением(Отказ)

Если Исполнитель.Пустая() Тогда
Исполнитель = ПараметрыСеанса.ТекущийИсполнитель;

КонецЕсли;

ДатаВыполнения = ТекущаяДата();

КонецПроцедуры

получение точки
Функция ПолучитьТочкуМаршрута()

Запрос = Новый Запрос;

Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 1
| НаМаршрутеТочкиМаршрута.НомерСтроки КАК НомерСтроки,
| НаМаршрутеТочкиМаршрута.Склад
|ИЗ
| БизнесПроцесс.НаМаршруте.ТочкиМаршрута КАК НаМаршрутеТочкиМаршрута
|
|ГДЕ
| (НаМаршрутеТочкиМаршрута.Склад НЕ В (ВЫБРАТЬ РАЗЛИЧНЫЕ
| ЭтапПути.Склад
| ИЗ
| Задача.ЭтапПути КАК ЭтапПути
| ГДЕ
| ЭтапПути.БизнесПроцесс = &БизнесПроцесс ))
| И (Ссылка = &БизнесПроцесс)
|УПОРЯДОЧИТЬ ПО
| НомерСтроки";

Запрос.УстановитьПараметр("БизнесПроцесс", Ссылка);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Возврат (Выборка.Склад);

Иначе
Возврат(Справочники.Склады.ПустаяСсылка());

КонецЕсли;

КонецФункции


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 16455
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по "Введение в конфигурирование в системе "1С: предприятие 8" основные объекты"

Автор TruthMan19Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 917
Последний ответ 28 Авг 2018, 02:25
от Golickoff
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7354
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4281
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5367
Последний ответ 06 Окт 2014, 15:23
от jenya1111

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
30 Сообщений
oooo800
29 Сообщений
LexaK
25 Сообщений
antoneus antoneus
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
alexandr_ll
14 Сообщений
мадам брошкина
13 Сообщений

* Кто онлайн

  • Точка Гостей: 440
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal