Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Окт 2018, 20:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос по бизнес -процессу  (Прочитано 2222 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Леонид

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-03
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Имеется бизнес-процесс,, в котором количество последовательных этапов определяется индивидуально на момент старта экземпляра процесса. Необходимоопределить этот процесс на старте по запросу. При этом процесс может  иметь очень долгий период (с утра и до вечера)


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
При использовании таких реквезитов адресации:
Пользователь (ссылка на справочник Пользователи);
Подразделение.
Считается что в регистре сведений, отвечающем за адресацию, соответствующие сведения измерения существуют.
Реквизиты задачи:
ДатаВыполнения (время выполнения задачи);
Исполнитель (ссылка на справочник пользователей системы);
Склад (ссылка на справочник складов)

обрабтка перед выполнением
Процедура ПередВыполнением(Отказ)

Если Исполнитель.Пустая() Тогда
Исполнитель = ПараметрыСеанса.ТекущийИсполнитель;

КонецЕсли;

ДатаВыполнения = ТекущаяДата();

КонецПроцедуры

получение точки
Функция ПолучитьТочкуМаршрута()

Запрос = Новый Запрос;

Запрос.Текст =
"ВЫБРАТЬ ПЕРВЫЕ 1
| НаМаршрутеТочкиМаршрута.НомерСтроки КАК НомерСтроки,
| НаМаршрутеТочкиМаршрута.Склад
|ИЗ
| БизнесПроцесс.НаМаршруте.ТочкиМаршрута КАК НаМаршрутеТочкиМаршрута
|
|ГДЕ
| (НаМаршрутеТочкиМаршрута.Склад НЕ В (ВЫБРАТЬ РАЗЛИЧНЫЕ
| ЭтапПути.Склад
| ИЗ
| Задача.ЭтапПути КАК ЭтапПути
| ГДЕ
| ЭтапПути.БизнесПроцесс = &БизнесПроцесс ))
| И (Ссылка = &БизнесПроцесс)
|УПОРЯДОЧИТЬ ПО
| НомерСтроки";

Запрос.УстановитьПараметр("БизнесПроцесс", Ссылка);

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Возврат (Выборка.Склад);

Иначе
Возврат(Справочники.Склады.ПустаяСсылка());

КонецЕсли;

КонецФункции


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 11555
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по "Введение в конфигурирование в системе "1С: предприятие 8" основные объекты"

Автор TruthMan19Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 109
Последний ответ 28 Авг 2018, 02:25
от Golickoff
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6475
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3650
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4221
Последний ответ 06 Окт 2014, 15:23
от jenya1111

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
71 Сообщений
MuI_I_Ika MuI_I_Ika
48 Сообщений
wise wise
38 Сообщений
byte777
37 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
LexaK
36 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 229
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal