Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 19:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос тест проффесионал 5 раздел. Сравнение, объядинение  (Прочитано 4542 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Предмет:
1С:Платформа
5.31 Какие действия необходимо выполнить в режиме "Сравнение,
объединение с конфигурацией из файла" для того, что бы в результирующем модуле объекта присутствовали строки из обоих исходных модулей?
 
1. Объединить с приоритетом основной конфигурации
2. Объединить с приоритетом файла
3. Взять из файла
4. Тексты модулей будут сохранены в любом случае
5. Верны ответы 1 и 2

Здравствуйте. Как я понимаю правильный ответ 5? В этом случае приоритет имеет значение если строки одинаковые?

Последний раз редактировалось: MuI_I_Ika; 21 Янв 2015, 19:52


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ответ 5.
в зависимости от того, у кого приоритет, будет комментироваться код: тот код, у которого приоритет выше остается, а тот, у которого ниже уходит в комментарии.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
В интернете правильный ответ. С приоритетом основной конфигурации.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
вы бы не поленились и проделали сами.
я вот сделал это за вас.
создал пустую конфигурацию, в ней справочник, к нему форму и процедуру "при открытии". написал код:
Процедура ПриОткрытии()
Сообщить("Привет мир!");
КонецПроцедуры
конфигурацию выгрузил в файл.
после этого изменил код на
Процедура ПриОткрытии()
Сообщить("после изменений");
КонецПроцедуры
далее последовательно объединил то с приоритетом основной конфигурации, то с приоритетом файла.
получил
Процедура ПриОткрытии()
//{{MRG[ <-> ]
Сообщить("после изменений");
//}}MRG[ <-> ]
//{{MRG[ <-> ]
// Сообщить("Привет мир!");
//}}MRG[ <-> ]
КонецПроцедуры
и
Процедура ПриОткрытии()
//{{MRG[ <-> ]
Сообщить("Привет мир!");
//}}MRG[ <-> ]
//{{MRG[ <-> ]
// Сообщить("после изменений");
//}}MRG[ <-> ]
КонецПроцедуры
соответственно.

ОТВЕТ 5.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
вы бы не поленились и проделали сами.
я вот сделал это за вас.

Избалуете ;)
Пусть сам ковыряется - больше пользы.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Пусть сам ковыряется - больше пользы.
это правильно, я просто направление задал на будущее :)
+ перепроверил сам себя - давно не приходилось объединением конфигураций заниматься, тем более, с объединением модулей - обычно все таки режим "взять из файла". вдруг позабыл чего, али поменяли (как тут недавно тема была про общие реквизиты - я то и не знал, что добавили :) отстаю от жизни...)

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
В интернете правильный ответ 1. Почему так не понятно? Понятно что логически даже не проверяя что ответ №5, но почему в интернете правильный ответ 1. :dfbsdfbsdf:

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
почему в интернете правильный ответ 1.
на заборе еще не то пишут ))


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Навигация

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
48 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 240
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal