Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 20:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: получить текущего пользователя  (Прочитано 12322 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн namak

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Ученик 1С
При создании формы хочу в поле внести текущего юзера.
создал общий модуль "СерверныеПроцедуры"
Функция ПараметрыСеансаТекущийПользователь() Экспорт
    Возврат ПараметрыСеанса.ТекущийПользователь;
КонецФункции

в модуле формы обработчик:
&НаКлиенте
Процедура ПриОткрытии(Отказ)
Если НЕ ЗначениеЗаполнено(Объект.Сотрудник) Тогда
Объект.Сотрудник = СерверныеПроцедуры.ПараметрыСеансаТекущийПользователь();
КонецЕсли;
КонецПроцедуры

все время выдается ошибка:
Цитировать
Переменная не определена (СерверныеПроцедуры)


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
А галочка у общего модуля стоит "Клиент(упр. приложение)" ?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн namak

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Ученик 1С
поставил галочку тоже
теперь выдает такое:
Цитировать
{ОбщийМодуль.СерверныеПроцедуры.Модуль(2,13)}: Переменная не определена (ПараметрыСеанса)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Убери галку Клиент(упр. прил) и Убери галку Глобальный
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн namak

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Ученик 1С
заработало без этих галочек...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Серьезно? Интересно почему?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн namak

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-09
  • Сайт: 
  • Профессия: Ученик 1С
ну попробую ответить.
галочку Глобальный убираем чтоб в глоб контексте создалось свойство с нашим именем СерверныеПроцедуры и уже через отсюда мы обращаемся к нашему методу (экспортируемому) ПараметрыСеансаТекущийПользователь().
галочка Сервер стоит чтоб методы были доступны только на сервере.
галочка Вызов сервера стоит чтоб мы из клиента могли вызывать метод наш метод


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4890
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1449
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2379
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 9980
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1903
Последний ответ 08 Сен 2015, 15:46
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
57 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 203
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal