Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 21:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматический расчет суммы из количества товаров и цены.  (Прочитано 4291 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн superjet

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-28
  • Сайт: 
  • Профессия: Ученик 1С
Перепутал темы.Это для версии 8.2 а не 7.7
Вопрос-если создана процедура РассчетСуммы .Зачем ссылку на нее прописывать в остальных процедурах
Процедура СписокТоваровКоличествоПриИзменении(Элемент)
Процедура СписокТоваровЦенаПриИзменении(Элемент)

Ведь она с виду может сама брать данные из Стр=Элементы.СписокТоваров.ТекущиеДанные;
То есть в этих данных уже находиться цена и количество.А потом умножать их и записывать данные в сумму.
Но если не прописать РассчетСуммы ();
 то цена не рассчитываеться.То есть логику понять.А то я начинаю только изучать программирование.

&НаКлиенте
Процедура СписокТоваровКоличествоПриИзменении(Элемент)
РассчетСуммы ();
КонецПроцедуры

&НаКлиенте
Процедура СписокТоваровЦенаПриИзменении(Элемент)
   РассчетСуммы()

КонецПроцедуры




&НаКлиенте
Процедура РассчетСуммы()
   Стр=Элементы.СписокТоваров.ТекущиеДанные;
   Стр.Сумма = Стр.Цена*Стр.Количество ;
КонецПроцедуры


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
логика такая, что система должна как-то понимать, в какой момент ту или иную процедуру выполнять. если все процедуры будут непрерывно перезапускаться и все время работать, боюсь даже представить что будет... :D
короче говоря, вызов процедуры в конкретном месте кода означает, что именно тут она должна выполниться, например при изменении количества или цены в вашем примере.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Возьмите Радченко "Практическое пособие разработчика" там такой пример очень хорошо описан! да и книгу прочитать будет вам полезно!
Помогли, отблагодари!

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
в радченко нужно глядеть!!+1
А так, ничего сложного нет в этом;)


Теги:
 

Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 473
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
Перенос товаров из д-та "Поступление Т и У" в "Отчет о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5161
Последний ответ 01 Июн 2011, 16:31
от Eugeneer
Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4294
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как добавить столбец "Номенклатура" в таблицу "Реализация товаров и услуг"

Автор ZanderBlackРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9867
Последний ответ 19 Ноя 2012, 11:12
от Gunner
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1084
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 267
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal