Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 21:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрет создания элементов в группах иерархического справочника  (Прочитано 4072 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн varaha

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-27
  • Сайт: 
  • Профессия: Программист 1С
Имеется иерархический справочник групп и элементов. Как сделать чтобы пользователь имел возможность создавать элементы только в самом нижнем уровне иерархии? То есть нужно реализовать иерархию групп, а элементы могут создаваться только в последней, самой нижней группе.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Можно попробовать при записи проверять максимальный уровень вложенности и уровень вложенности элемента который пользователь пытается записать если уровень вложенности элемента ниже максимального запрещать запись
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн varaha

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-11-27
  • Сайт: 
  • Профессия: Программист 1С
вот что получилось:

&НаКлиенте
Процедура СписокПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа)
Если не Группа Тогда // создается элемент, а не группа
Если Элемент.ТекущаяСтрока.Пустая() Тогда  // на случай выбора корня в дереве
Отказ=истина;
Предупреждение("Выберите улицу!");
Иначе
         Если КоличествоУровнейИерархииОграничено() тогда
       Если не Группа и УровеньИерархии(Элемент.ТекущаяСтрока)<КоличествоУровнейИерархии()-2 тогда
    Отказ=истина;
   КонецЕсли;
   КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция УровеньИерархии(с)
возврат с.Уровень();
КонецФункции

 &НаСервереБезКонтекста
Функция КоличествоУровнейИерархии()
возврат Метаданные.Справочники.Плательщики.КоличествоУровней;
КонецФункции

&НаСервереБезКонтекста
Функция КоличествоУровнейИерархииОграничено()
возврат Метаданные.Справочники.Плательщики.ОграничиватьКоличествоУровней;
КонецФункции

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6494
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 622
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2032
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 323
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal