Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как поменять период???  (Прочитано 3269 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн For

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Можно ли поменять период у записей периодического независимого регистра, соответствующих ряду условий, которые задаются уже по ходу выполнения программы


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Главное здесь- изменить записи регистра, Сам результат запроса – таблица, в которой по каждой записи заполнены все поля измерений из регистра и поле Период.

Процедура ЗаменаПериода()

Запрос = Новый Запрос;

Запрос.Текст =
"ВЫБРАТЬ
| ОтветственныеЛицаОрганизации.Период,
| ОтветственныеЛицаОрганизации.СтруктурнаяЕдиница,
| ОтветственныеЛицаОрганизации.ОтветственноеЛицо
|ИЗ
| РегистрСведений.ОтветственныеЛицаОрганизации КАК ОтветственныеЛицаОрганизации
|ГДЕ
| ОтветственныеЛицаОрганизации.Период <= ДАТАВРЕМЯ(2005, 1, 1)
| И
| ОтветственныеЛицаОрганизации.СтруктурнаяЕдиница.Наименование ПОДОБНО ""Групп-Трейдинг""
| И
| (ОтветственныеЛицаОрганизации.Должность.Наименование ЕСТЬ NULL
| ИЛИ
| НЕ(ОтветственныеЛицаОрганизации.Должность.Наименование ПОДОБНО ""Продавец""
| ИЛИ
| ОтветственныеЛицаОрганизации.Должность.Наименование ПОДОБНО ""Кладовщик""))";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Запись = РегистрыСведений.ОтветственныеЛицаОрганизации.СоздатьМенеджерЗаписи();

Пока Выборка.Следующий() Цикл

Запись.Период   = Выборка.Период;
Запись.СтруктурнаяЕдиница = Выборка.СтруктурнаяЕдиница;
Запись.ОтветственноеЛицо  = Выборка.ОтветственноеЛицо;

Запись.Прочитать();
 
Если Запись.Выбран() Тогда
Запись.Период = Дата(2004, 1, 1);

Запись.Записать();

КонецЕсли;

КонецЦикла;

КонецПроцедуры;


Теги:
 

"Период не может быть пустым..."

Автор alexbelРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4669
Последний ответ 25 Янв 2015, 20:17
от alexbel
Флаг "Запомнить выбранный период" на стандартной форме

Автор Екатерина ВершининаРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 452
Последний ответ 13 Дек 2016, 10:30
от Екатерина Вершинина
Как сделать простой отчет "Отработано выходных дней за период"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 246
Последний ответ 06 Окт 2017, 12:25
от alex0402
Страховые взносы, которые были начислены в период применения УСН, теперь можно учесть для целей налога на прибыль

Автор newsРаздел Новости

Ответов: 0
Просмотров: 669
Последний ответ 06 Фев 2015, 12:51
от news
Сотрудники, приостановившие работу в связи с задержкой выплаты зарплаты, должны получать средний заработок в период простоя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 994
Последний ответ 23 Дек 2015, 14:18
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 250
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal