Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Окт 2018, 08:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как поменять период???  (Прочитано 3599 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн For

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Можно ли поменять период у записей периодического независимого регистра, соответствующих ряду условий, которые задаются уже по ходу выполнения программы


Оффлайн Никитина

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
Главное здесь- изменить записи регистра, Сам результат запроса – таблица, в которой по каждой записи заполнены все поля измерений из регистра и поле Период.

Процедура ЗаменаПериода()

Запрос = Новый Запрос;

Запрос.Текст =
"ВЫБРАТЬ
| ОтветственныеЛицаОрганизации.Период,
| ОтветственныеЛицаОрганизации.СтруктурнаяЕдиница,
| ОтветственныеЛицаОрганизации.ОтветственноеЛицо
|ИЗ
| РегистрСведений.ОтветственныеЛицаОрганизации КАК ОтветственныеЛицаОрганизации
|ГДЕ
| ОтветственныеЛицаОрганизации.Период <= ДАТАВРЕМЯ(2005, 1, 1)
| И
| ОтветственныеЛицаОрганизации.СтруктурнаяЕдиница.Наименование ПОДОБНО ""Групп-Трейдинг""
| И
| (ОтветственныеЛицаОрганизации.Должность.Наименование ЕСТЬ NULL
| ИЛИ
| НЕ(ОтветственныеЛицаОрганизации.Должность.Наименование ПОДОБНО ""Продавец""
| ИЛИ
| ОтветственныеЛицаОрганизации.Должность.Наименование ПОДОБНО ""Кладовщик""))";

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Запись = РегистрыСведений.ОтветственныеЛицаОрганизации.СоздатьМенеджерЗаписи();

Пока Выборка.Следующий() Цикл

Запись.Период   = Выборка.Период;
Запись.СтруктурнаяЕдиница = Выборка.СтруктурнаяЕдиница;
Запись.ОтветственноеЛицо  = Выборка.ОтветственноеЛицо;

Запись.Прочитать();
 
Если Запись.Выбран() Тогда
Запись.Период = Дата(2004, 1, 1);

Запись.Записать();

КонецЕсли;

КонецЦикла;

КонецПроцедуры;


Теги:
 

"Период не может быть пустым..."

Автор alexbelРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6358
Последний ответ 25 Янв 2015, 20:17
от alexbel
Флаг "Запомнить выбранный период" на стандартной форме

Автор Екатерина ВершининаРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 735
Последний ответ 13 Дек 2016, 10:30
от Екатерина Вершинина
Не формируется отчёт по дате с типом "Стандартный период"

Автор jetdiggerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 175
Последний ответ 02 Окт 2018, 11:11
от wise
Как сделать простой отчет "Отработано выходных дней за период"

Автор NewbieDinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 675
Последний ответ 06 Окт 2017, 12:25
от alex0402
Страховые взносы, которые были начислены в период применения УСН, теперь можно учесть для целей налога на прибыль

Автор newsРаздел Новости

Ответов: 0
Просмотров: 814
Последний ответ 06 Фев 2015, 12:51
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
70 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
byte777
37 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
36 Сообщений
wise wise
35 Сообщений
LexaK
32 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 363
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal