Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 12:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите сделать условие.  (Прочитано 1430 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vurdalak

  • ***
  • Сообщений: 229
  • РЕПУТАЦИЯ: 8
  • КПД: 3%
  • Регистрация: 2010-08-11
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 1с 8.1 Конфигурация Альфа Авто. Есть документ Банковская выписка в ней я делаю модификацию. Из текущей строки табчасти "Состав" беру колонку сделка, потом вытаскиваю из выбранного пользователем документа "Поступление автомобилей" сумму и наименование автомобиля. Нужно сделать условие при котором мой код бы исполнялся только когда  выбран документ "Поступление Автомобилей". В коде я написал где оно должно быть.


Процедура СоставПриАктивизацииСтроки(Элемент)
Если  ЭлементыФормы.Состав.ТекущаяСтрока = Неопределено Тогда
Возврат;
КонецЕсли;
Сделка = ЭлементыФормы.Состав.ТекущаяСтрока.Сделка;
//Если Сделка = Документы.ПоступлениеАвтомобилей Тогда Вот тут должно начинатся условие
Для Каждого ТекЭлемент Из Сделка.Автомобили Цикл
Если Текэлемент.Взалог = Истина Тогда
   ЭлементыФормы.ОплатаАвтомобилей.ДобавитьСтроку();
   ЭлементыФормы.ОплатаАвтомобилей.ТекущаяСтрока.Сумма = ТекЭлемент.Сумма;
   ЭлементыФормы.ОплатаАвтомобилей.ТекущаяСтрока.Автомобиль = ТекЭлемент.Автомобиль;
   КонецЕсли
КонецЦикла;
//КонецЕсли; Вот тут заканчиваться. Как я написал не работает.





КонецПроцедуры



Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Очевидно вы хотите такое условие:

Если ТипЗнч(Сделка) = Тип("ДокументСсылка.ПоступлениеАвтомобилей") Тогда

Оффлайн vurdalak

  • ***
  • Сообщений: 229
  • РЕПУТАЦИЯ: 8
  • КПД: 3%
  • Регистрация: 2010-08-11
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо большое))


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5885
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4365
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 791
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal