Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УТ 11, внешняя печ форма  (Прочитано 1805 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
Внешняя обработка.Не удаётся посчитать сумму в таблице значений
  ТЗМля = Новый ТаблицаЗначений;
 ТЗМля.Колонки.Добавить("Колонка");
 
 Пока ВыборкаСтрокТовары.Следующий() Цикл
Область.Параметры.Заполнить(ВыборкаСтрокТовары);
КолВо = ВыборкаСтрокТовары.Количество;
НоваяСтрока = ТЗМля.Добавить();
НоваяСтрока = КолВо;
  КонецЦикла;
 К = ТЗМля.Итог("Колонка");
     Сообщить(К);
Значение К ноль :(


Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
Тема закрыта
НоваяСтрока = ТЗМля.Добавить();
НоваяСтрока.Количество = ВыборкаСтрокТовары.Количество; //+

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Не понимаю зачем для этого Таблица значений!!! НО
 
 ТЗМля = Новый ТаблицаЗначений; 
 ТЗМля.Колонки.Добавить("Колонка");
 
 Пока ВыборкаСтрокТовары.Следующий() Цикл
Область.Параметры.Заполнить(ВыборкаСтрокТовары);
КолВо = ВыборкаСтрокТовары.Количество;
НоваяСтрока = ТЗМля.Добавить();
НоваяСтрока.Колонка = КолВо;
  КонецЦикла;
 К = ТЗМля.Итог("Колонка");
     Сообщить(К);
или же все проще: 
КолВо = 0;
 Пока ВыборкаСтрокТовары.Следующий() Цикл
Область.Параметры.Заполнить(ВыборкаСтрокТовары);
КолВо = КолВо+ВыборкаСтрокТовары.Количество; 
  КонецЦикла;
     Сообщить(КолВо);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 358
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal