Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проведение документа  (Прочитано 1564 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    // регистр Движение Приход
    Движения.Движение.Записывать = Истина;
    Движения.Движение.Очистить();
    Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
        Движение = Движения.Движение.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТабличнаяЧасть1.Наименование_корма;
        Движение.Склад = ТекСтрокаТабличнаяЧасть1.Склад;
        Движение.Факт = ТекСтрокаТабличнаяЧасть1.кол_во;
        Движение.Номер = Номер;
    КонецЦикла;

     // регистр Движение Расход
    Движения.Движение.Записывать = Истина;
    Движения.Движение.Очистить();
    Запрос = Новый Запрос;
    Запрос.Текст =
   
    "ВЫБРАТЬ
   | Номенклатура.НаименованиеСырья,
   | Номенклатура.ПроцентВвода,
   | Номенклатура.Ссылка.Наименование
   |ИЗ
   | Справочник.Номенклатура.ТабличнаяЧасть1 КАК Номенклатура";
                                                                             
    Результат = Запрос.Выполнить();
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
       Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
                   наим=строка(ТекСтрокаТабличнаяЧасть1.Наименование_корма);
           кол_во=ТекСтрокаТабличнаяЧасть1.кол_во;
               Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
             наимНом=ВыборкаДетальныеЗаписи.наименование;
               если (наим=наимНом) тогда
                 Движение = Движения.Движение.Добавить();
                 Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
                 Движение.Номенклатура = ВыборкаДетальныеЗаписи.НаименованиеСырья;
                 Движение.Период = Дата;
                 Движение.Факт = (ВыборкаДетальныеЗаписи.ПроцентВвода*кол_во)/100;
                 Движение.Номер = Номер;
              конецесли;
           КонецЦикла;
     КонецЦикла;
                                       

    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры





\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\

вообщем, работает либо когда провожу приход либо расход, а вместе не работает, не могли бы подсказать в чем может быть причина?((


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Лучше опишите, что пытаетесь добиться. Ибо написана глупость...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
спасибо, если не смогли разобраться, то это не значит что написана глупость)) сам всё сделал, если интересно, чего я хотел добиться пишите в личку.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Поддерживаю cska-fanat-kz написана ГЛУПОСТЬ
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15923
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 625
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 766
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal