Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Сен 2020, 19:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как самому заполнить дерево значений?  (Прочитано 16642 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Регистрация: 2009-11-03
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Нужна обработка данных иерархически поэтому нужно заполнять (а главное сначала создать) данные в каталоге "дерева". Но при запросе, данные перекидывеются на рандоме из таблицы, а как самостоятельно выбирать и заполнять нужные элементы дерева?


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
1. создаем обработку
далее следует запись данных в дерево значений
Цитировать
Процедура ЗаполнениеДерева(Кнопка)

   Дерево.Колонки.Очистить();
   Дерево.Колонки.Добавить("ИмяКолонки");

   // Создать первую строку. Правильнее сказать – создать элемент коллекции.
   // Он помещается в переменную "СтрокаВерхнегоУровня".
   СтрокаВерхнегоУровня = Дерево.Строки.Добавить();

   // В колонку "ИмяКолонки" записать значение "Старшая".
   СтрокаВерхнегоУровня.ИмяКолонки = "Старшая";
   
   // Создать строку, подчиненную "Старшей".
   ПодчиненнаяСтрока = СтрокаВерхнегоУровня.Строки.Добавить();
   ПодчиненнаяСтрока.ИмяКолонки = "Первая подчиненная";
   
   ПодчиненнаяВторогоУровня = ПодчиненнаяСтрока.Строки.Добавить();
   ПодчиненнаяВторогоУровня.ИмяКолонки = "Первая нижняя";
   
   ПодчиненнаяВторогоУровня = ПодчиненнаяСтрока.Строки.Добавить();
   ПодчиненнаяВторогоУровня.ИмяКолонки = "Вторая нижняя";
   
   ПодчиненнаяСтрока = СтрокаВерхнегоУровня.Строки.Добавить();
   ПодчиненнаяСтрока.ИмяКолонки = "Вторая подчиненная";

   // Использование метода позволит увидеть результат работы
   // с деревом значений в табличном поле.
   ЭлементыФормы.Дерево.СоздатьКолонки();

КонецПроцедуры


++++!!!! :befhbt: :befhbt: :befhbt: :befhbt:
не забываем установить текущее значение
Цитировать
Процедура ОткрытиеВетки(Кнопка)

   // Сделать текущим именно элемент коллекции "Строки".
   РезультатПоиска = Дерево.Строки.Найти("Первая нижняя", "ИмяКолонки", Истина);

   Если РезультатПоиска <> Неопределено Тогда
      ЭлементыФормы.Дерево.ТекущаяСтрока = РезультатПоиска;   

   КонецЕсли;   

КонецПроцедуры


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка [&quot;обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 6153
Последний ответ 20 Мар 2018, 16:54
от alex0402
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 5207
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 8478
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 32001
Последний ответ 13 Фев 2011, 17:36
от proofet
Права на просмотр "Редактирование законодательных значений"

Автор Эля 123Раздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 1559
Последний ответ 23 Июл 2018, 12:24
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
77 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 381
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal