Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Ноя 2020, 07:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Строка в ВПФ итоговая строка, сумма прописью  (Прочитано 26116 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ali50

  • ***
  • Сообщений: 100
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
один вопрос видимо глупый что за код Вам нужен в смысле где он находится?


Оффлайн Gunner

  • ****
  • Сообщений: 296
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
:D программный код, в модуле, который у вас на первом скриншоте

Оффлайн ali50

  • ***
  • Сообщений: 100
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
И Вы знаете я только заметил у меня на печать выходит только последняя строка товара из всех
Добавлено: 19 Ноя 2012, 16:43

скажите пожалуйста Вы получили скриншот?

Последний раз редактировалось: ali50; 19 Ноя 2012, 16:43

Оффлайн Gunner

  • ****
  • Сообщений: 296
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Я просил скопированный код, а не скриншот (так можно редактировать, а не писать вручную с нуля), ну ладно, тогда опишу как надо сделать.
1) После строчки ЗаполнитьЗначенияСвойств... выведите секцию ТабДок.Вывести(СекцияСтрока)
2) удалите вашу строчку ТабДок.Вывести(СекцияСтрока)
Теперь будут выводиться все строки таблицы
3) До строчки Для каждого..  получите количество строк табл.части Количество = СсылкаНаОбъект.Товары.Количество();
4) До вывода СекцияСуммаПрописью заполните параметр ИтоговаяСтрока. СекцияСуммаПрописью.Параметры.ИтоговаяСтрока = "

Оффлайн ali50

  • ***
  • Сообщений: 100
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
Вот скапированый код а вот что получилось когда я сделал все как Вы написали
Добавлено: 19 Ноя 2012, 17:22


Функция Печать() Экспорт
   
   ТабДок = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("ТестовыйМакет");
   
   СекцияЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   СекцияПоставщик = Макет.ПолучитьОбласть("Поставщик");
   СекцияПокупатель = Макет.ПолучитьОбласть("Покупатель");
   СекцияАдресДоставки = Макет.ПолучитьОбласть("АдресДоставки");   
   СекцияШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   СекцияСтрока = Макет.ПолучитьОбласть("Строка");
   СекцияИтого = Макет.ПолучитьОбласть("Итого");
   СекцияИтогоНДС = Макет.ПолучитьОбласть("ИтогоНДС");
   
   СекцияСуммаПрописью = Макет.ПолучитьОбласть("СуммаПрописью");
   СекцияПодписи = Макет.ПолучитьОбласть("Подписи");
   
   СекцияЗаголовок.Параметры.НомерДок = СсылкаНаОбъект.Номер;
    СекцияЗаголовок.Параметры.ДатаДок = СсылкаНаОбъект.Дата;
   
   СекцияПоставщик.Параметры.ПредставлениеПоставщика = СсылкаНаОбъект.Организация;
   СекцияПокупатель.Параметры.ПредставлениеПолучателя = СсылкаНаОбъект.Контрагент;
   СекцияАдресДоставки.Параметры.АдресДоставки = СсылкаНаОбъект.АдресДоставки;
   СекцияКоличество = СсылкаНаОбъект.Товары.Количество();
   
   Для каждого СтрокаТаблицы Из СсылкаНаОбъект.Товары Цикл
   
   ЗаполнитьЗначенияСвойств(СекцияСтрока.Параметры,СтрокаТаблицы);
    ТабДок.Вывести(СекцияСтрока);
   
КонецЦикла;
   
   
   
   СекцияИтого.Параметры.Всего = СсылкаНаОбъект.СуммаДокумента;
      

      
    ТабДок.Вывести(СекцияЗаголовок);                                    
   ТабДок.Вывести(СекцияПоставщик);
   ТабДок.Вывести(СекцияПокупатель);
   ТабДок.Вывести(СекцияАдресДоставки);
   ТабДок.Вывести(СекцияШапкаТаблицы);
   //ТабДок.Вывести(СекцияСтрока);
   ТабДок.Вывести(СекцияИтого);
   ТабДок.Вывести(СекцияИтогоНДС);
   ТабДок.Вывести(СекцияСуммаПрописью);
   ТабДок.Вывести(СекцияПодписи);
   
   Возврат ТабДок;
   
КонецФункции

Пардон забыл вставить скопированный код   

   
Добавлено: 19 Ноя 2012, 18:26

как хорошо что Вы вернулись не могу понять 4 пункт Ваших указаний вот что я сделал

Функция Печать() Экспорт
   
   ТабДок = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("ТестовыйМакет");
   
   СекцияЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   СекцияПоставщик = Макет.ПолучитьОбласть("Поставщик");
   СекцияПокупатель = Макет.ПолучитьОбласть("Покупатель");
   СекцияАдресДоставки = Макет.ПолучитьОбласть("АдресДоставки");   
   СекцияШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   СекцияСтрока = Макет.ПолучитьОбласть("Строка");
   СекцияИтого = Макет.ПолучитьОбласть("Итого");
   //СекцияИтогоНДС = Макет.ПолучитьОбласть("ИтогоНДС");
   
   
   //СекцияСуммаПрописью.Параметры.ИтоговаСтрока = Макет.ПолучитьОбласть("ИтоговаяСтрока");
   СекцияСуммаПрописью.Параметры.ИтоговаяСтрока = СсылкаНаОбъект.ИтоговаяСтрока;
   
   
   
   
   СекцияСуммаПрописью = Макет.ПолучитьОбласть("СуммаПрописью");
   СекцияПодписи = Макет.ПолучитьОбласть("Подписи");
   
   СекцияЗаголовок.Параметры.НомерДок = СсылкаНаОбъект.Номер;
    СекцияЗаголовок.Параметры.ДатаДок = СсылкаНаОбъект.Дата;
   
   СекцияПоставщик.Параметры.ПредставлениеПоставщика = СсылкаНаОбъект.Организация;
   СекцияПокупатель.Параметры.ПредставлениеПолучателя = СсылкаНаОбъект.Контрагент;
   СекцияАдресДоставки.Параметры.АдресДоставки = СсылкаНаОбъект.АдресДоставки;
   
   ТабДок.Вывести(СекцияЗаголовок);                                    
   ТабДок.Вывести(СекцияПоставщик);
   ТабДок.Вывести(СекцияПокупатель);
   ТабДок.Вывести(СекцияАдресДоставки);
   ТабДок.Вывести(СекцияШапкаТаблицы);
   
   Количество = СсылкаНаОбъект.Товары.Количество();
   
Для каждого СтрокаТаблицы Из СсылкаНаОбъект.Товары Цикл
   
   ЗаполнитьЗначенияСвойств(СекцияСтрока.Параметры,СтрокаТаблицы);
    ТабДок.Вывести(СекцияСтрока);
   
КонецЦикла;
   
   СекцияИтого.Параметры.Всего = СсылкаНаОбъект.СуммаДокумента;
      
    ТабДок.Вывести(СекцияИтого);
   //ТабДок.Вывести(СекцияИтогоНДС);
   ТабДок.Вывести(СекцияСуммаПрописью);
   ТабДок.Вывести(СекцияПодписи);
   
   Возврат ТабДок;
   
КонецФункции

   

   
Добавлено: 19 Ноя 2012, 18:29

у меня все получилось кроме 3и4 пункта
Добавлено: 19 Ноя 2012, 18:41

Gunner объясните пожалуйста что я сделал не так в 3 и 4 пунктах

Последний раз редактировалось: ali50; 19 Ноя 2012, 18:41

Оффлайн Gunner

  • ****
  • Сообщений: 296
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Вот так
Функция Печать() Экспорт
   
   ТабДок = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("ТестовыйМакет");
   
   СекцияЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   СекцияПоставщик = Макет.ПолучитьОбласть("Поставщик");
   СекцияПокупатель = Макет.ПолучитьОбласть("Покупатель");
   СекцияАдресДоставки = Макет.ПолучитьОбласть("АдресДоставки");   
   СекцияШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   СекцияСтрока = Макет.ПолучитьОбласть("Строка");
   СекцияИтого = Макет.ПолучитьОбласть("Итого");
   СекцияИтогоНДС = Макет.ПолучитьОбласть("ИтогоНДС");
   СекцияСуммаПрописью = Макет.ПолучитьОбласть("СуммаПрописью");
   СекцияПодписи = Макет.ПолучитьОбласть("Подписи");
   
    //Заголовок
   СекцияЗаголовок.Параметры.НомерДок = СсылкаНаОбъект.Номер;
   СекцияЗаголовок.Параметры.ДатаДок = СсылкаНаОбъект.Дата;
   ТабДок.Вывести(СекцияЗаголовок);   
   //Поставщик
   СекцияПоставщик.Параметры.ПредставлениеПоставщика = СсылкаНаОбъект.Организация;
   ТабДок.Вывести(СекцияПоставщик);
   //Покупатель
   СекцияПокупатель.Параметры.ПредставлениеПолучателя = СсылкаНаОбъект.Контрагент;
   ТабДок.Вывести(СекцияПокупатель);
   //АдресДоставки
   СекцияАдресДоставки.Параметры.АдресДоставки = СсылкаНаОбъект.АдресДоставки;
   ТабДок.Вывести(СекцияАдресДоставки);
   //Шапка
   ТабДок.Вывести(СекцияШапкаТаблицы);
   //Строка
   Для каждого СтрокаТаблицы Из СсылкаНаОбъект.Товары Цикл
       ЗаполнитьЗначенияСвойств(СекцияСтрока.Параметры,СтрокаТаблицы);
       ТабДок.Вывести(СекцияСтрока);
   КонецЦикла;
   //Итого
   СекцияИтого.Параметры.Всего = СсылкаНаОбъект.СуммаДокумента;
   ТабДок.Вывести(СекцияИтого);
   //ИтогоНДС
   ТабДок.Вывести(СекцияИтогоНДС);
   //СуммаПрописью
   Количество = Функция(); //здесь вызываете функцию, в которой высчитывается количество различных наименований в табл.части документа
   СекцияСуммаПрописью.Параметры.ИтоговаяСтрока = "Всего наименований "+Количество+" на сумму "+СсылкаНаОбъект.СуммаДокумента+" руб.";
   СекцияСуммаПрописью.Параметры.ИтогоСуммаПрописью = ЧислоПрописью(СсылкаНаОбъект.СуммаДокумента,"...что-то там..."); //используйте функцию ЧислоПрописью(), см. Синтаксис-помощник 
   ТабДок.Вывести(СекцияСуммаПрописью);
   //Подписи
   ТабДок.Вывести(СекцияПодписи);
   
   Возврат ТабДок;
   
КонецФункции

Оффлайн ali50

  • ***
  • Сообщений: 100
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
а можно то что Вы прислали ни чего не меняя скопировать в программу будет работать?

Оффлайн Gunner

  • ****
  • Сообщений: 296
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Будет, но только надо закомментирвоать 3 строчки, где рассчитываются параметры секции сумма прописью, там надо доработать. Пока будет только без суммы прпоисью

Оффлайн ali50

  • ***
  • Сообщений: 100
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
а как ее доработать? подскажите пожалуйста

Оффлайн Gunner

  • ****
  • Сообщений: 296
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Я итак подсказал, дал "дочку" так сказать :)


Теги:
 

Запрос (или не запрос) : по условию, количество строк ТЧ и сумма всех строк ТЧ по определенному реквизиту всех элементов справоника во всех подгруппах группы

Автор oooo800Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 276
Последний ответ 18 Сен 2020, 17:33
от oooo800
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1942
Последний ответ 24 Янв 2018, 02:38
от Геннадий ОбьГЭС
колонка "сумма"

Автор otabekРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3103
Последний ответ 01 Мар 2014, 14:13
от DmitriyF
выгрузка в УПП через Конвертацию "Проведение документа: Платежное поручение исходящее Не совпадают сумма документа и ее расшифровка"

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1320
Последний ответ 03 Янв 2019, 00:00
от Св Ч
Общая Сумма Документов в Списке Документов

Автор Andrey777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1575
Последний ответ 13 Дек 2016, 15:27
от ilyay

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
33 Сообщений
DmitriyF DmitriyF
30 Сообщений
alexandr_ll
22 Сообщений
MuI_I_Ika MuI_I_Ika
17 Сообщений
LexaK
13 Сообщений
antoneus antoneus
10 Сообщений
Дидар Оразалы Дидар Оразалы
9 Сообщений
gribok
9 Сообщений
Каримдат Каримдат
7 Сообщений
Yamuna
7 Сообщений

* Кто онлайн

  • Точка Гостей: 110
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal