Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Возможно ли портирование отчета из 7.7 в 8.2  (Прочитано 2296 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Есть такая проблема перевести отчет из 7.7 в 8.2.
Пробовал через СКД, но что-то не получается то что нужно....
Необходимо проанализировать движения по счету учета НДС (68.2 или 68.02) типа шахматки, но только отчет шахматка вообще не подходит по структуре..
Вообще возможно переписать код, например есть старый код но новый реализован по другому, т.е. получится что нужно перепечатать по логике 8-ой версии?
Вот кусок кода:
Перем  ТаблЗнач;
Перем Расшифровка,ВыбДокумВид;
//-----------------------------------------------
Функция РасшифровкаДтКт(ДтКт)
   Расшифровка.Установить("ДтКт", ДтКт);
   Возврат Расшифровка;
КонецФункции
               
//_____________________________________________________________________________

Процедура НапечататьТЗ(ТЗ)
   табВывод = СоздатьОбъект("Таблица");
   КоличествоКолонок=ТЗ.КоличествоКолонок();
   
   Для Сч=1 По КоличествоКолонок Цикл
      колонка = "";
      ТЗ.ПолучитьПараметрыКолонки(Сч,,,,Колонка,,,);
      текЯчейка = табВывод.Область(1,Сч,1,Сч);
      текЯчейка.Текст = колонка;
   КонецЦикла;
        
   ТЗ.ВыбратьСтроки();
   Пока ТЗ.ПолучитьСтроку()=1 Цикл
      Для Сч=1 По КоличествоКолонок Цикл
         Значение = ТЗ.ПолучитьЗначение(ТЗ.НомерСтроки,Сч);
         текЯчейка = табВывод.Область(ТЗ.НомерСтроки+1,Сч,ТЗ.НомерСтроки+1,Сч);
         текЯчейка.Текст = Значение;
      КонецЦикла;
   КонецЦикла;
   
    табВывод.Показать();
КонецПроцедуры


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Отчет нужно переписать ручками.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Отчет правил ручками, но вот такая загвоздка сейчас, на строчке выделенная красным цветом
	Таб = Новый ТаблицаЗначений;
Таб.ИсходнаяТаблица("Сформировать");
[color=red]Ит = СоздатьОбъект("БухгалтерскиеИтоги");[/color]
Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "68.2",,, 2, "Проводка", "С");
Я так понял, что тут нужен запрос, но в каком виде?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Заменить на запрос к регистру бухгалтерии
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
итак что-то уже вышло из моего отчета, НО появились 2 проблемы - почему то 10 записей на каждый документ, причем одинаковых ну и когда например начало периода выбирается, то например с 2009 года, то вкрадываются записи 2008 года.


нее..че то гоню..вроде нормально выводится=)А вот не сортируется по периоду=)
Добавлено: 20 Ноя 2012, 17:09

Проблемы с итогами...вывожу по регистратору, вчем может быть проблема?
Добавлено: 21 Ноя 2012, 11:12

Все сделал, все вопросы решил,теперь все корректно отображается, а так же вид документов теперь группируется все ок=) Если у кого есть вопросы, спрашивайте;)

Последний раз редактировалось: markgenuine; 21 Ноя 2012, 11:12


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7063
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3000
Последний ответ 27 Май 2015, 10:02
от casper009
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4099
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3878
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1961
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal