Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Окраска строки табличного поля по условию  (Прочитано 8972 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Есть задача,в УТ 10.3, в документе "Перемещение товаров" имеется два табличных поля на разных закладках и нужно сравнить позиции номенклатуры, т.е. если во второй ТЧ нет позиции а в первой есть то она окрашивается в красный цвет, а если совпадают позиции то цвет остается неизменным. Позиции сравниваются по наименованию. Попробовал накидать код, вот все что удалось сделать, но ни чего не получается :dfbsdfbsdf: . я новичек в программировании поэтому прошу помощи!



Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
   СтруктураДляПоиска1 = Новый Структура("Номенклатура", ЭлементыФормы.Товары.ТекущаяСтрока.Номенклатура);
   МассивСтрок1 = Товары.НайтиСтроки(СтруктураДляПоиска1);

       
        СтруктураДляПоиска2 = Новый Структура("Номенклатура", Прием.ТекущаяСтрока.Номенклатура);
   МассивСтрок2 = ПриемНаСклад.НайтиСтроки(СтруктураДляПоиска2);



Для каждого СтрокаСписка Из МассивСтрок1 Цикл      
   Если ????    тогда
      СтрокаСписка.ЦветФона = Новый Цвет(155, 155, 155);      
   КонецЕсли;
КонецЦикла; 
КонецПроцедуры



Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
как присвоить цвет строке знаю, подскажите как сравнить строки двух табличных частей?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Ну вообще, алгоритм тут совсем не хитрый. Если он вызывает у вас сложности, скорее всего, вам нужно получить какое-то базовое образование (не по 1С) ну или на худой конец почитать что-то.

По теме: номенклатурные позиции должны быть в строках с тем же номером, или это не важно, главное, чтобы номенклатура была в обоих таблицах?

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
номенклатура будет в обеих таблицах одинакова по коду, но если позиции нет во второй ТЧ то в первой она подсвечивается красным.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
lia171, судя по вашему ответу, вы не поняли мой вопрос. ну либо не смогли сформулировать свою мысль.
в общем я не понял, при чем тут вообще код, когда объектные данные (как то справочник или документ) надо сравнивать по ссылке, ну не суть.

итак, еще раз попробую сформулировать задачу, как я ее понял из всего написанного вами: есть 2 таблицы А и Б, в обоих есть колонка Номенклатура (тип СправочникСсылка.Номенклатура), нужно в таблице А выделить цветом все строки, Номенклатура в которых не найдено в таблице Б (ну то есть нет в таблице Б такой номенклатуры).
Верно?

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Нет ничего проще :)
Суть алгоритма: проходим в цикле по строкам ТЧ А, проверяем, есть ли Номенклатура в Б, если нет - подсвечиваем.
Вот вам примерный вид кода (на основе вашего первого поста):
Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
Если Прием.Найти(ОформлениеСтроки.ДанныеСтроки.Номенклатура) = Неопределено Тогда
ОформлениеСтроки.ЦветФона = Новый Цвет(155, 155, 155);
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
а прием - это обращение к ТЧ-2?
Добавлено: 17 Ноя 2012, 21:51

и правда просто), может подскажете какую умную литературу по программированию 1с? А то много всего не знаю за что взяться. спасибо!

Последний раз редактировалось: lia171; 17 Ноя 2012, 21:51

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
всегда всем советую Радченко. а вообще, ищите по форуму. подобные вопросы тут задавались уже очень много раз. сейчаст нет времени ответить подробнее/поискать самому, может завтра скину ссылки на темы на нашем же форуме, ну или быстрее найдите самостоятельно.
Добавлено: 17 Ноя 2012, 23:26

а прием - это обращение к ТЧ-2?
да.
честно, не особо вчитывался в ваш первоначальный код (поскольку при беглом осмотре сразу было понятно, что он не правильный), поэтому взял то имя переменной, какое попалось на глаза и это была строка
СтруктураДляПоиска2 = Новый Структура("Номенклатура", Прием.ТекущаяСтрока.Номенклатура);
сейчас уже после вашего вопроса посмотрел код внимательнее и понял, что вторая ТЧ по всей видимости называется ПриемНаСклад.
Ну в общем, главное - суть алгоритма вы поняли.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
да да, с этим вы угадали), суть понял, щас надо количество сравнить


Теги:
 

Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2475
Последний ответ 31 Дек 2011, 11:36
от AntonB
Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6870
Последний ответ 24 Ноя 2014, 12:21
от gigson
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4201
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3237
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8531
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
156 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal