Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 21:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Непонятные моменты  (Прочитано 2887 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nr1

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-06
  • Сайт: 
  • Профессия: Ученик 1С
Товарищи, скажите, что в этом коде должно быть перед функцией написано, чтобы она "сообщалась" (Ошибка - Недостаточно фактических параметров..) :(

Процедура ПриНачалеРаботыСистемы()
   Предупреждение("Загрузилась автоматическая система бомбардировки Пентагона!!!
                  |Нажмите ОК для начала операции наведения",10,"Уничтожение врага средствами 1С");
   Сообщить ("Каюк Америке наступит " + (ТекущаяДата()+60*60));
   Сообщить("С прошлой гранидиозной пьянки прошло "+ДеньГода(ТекущаяДата()) + " дней");
      Сообщить("Дней до Нового года "+ЧТО ЗДЕСЬ ДОЛЖНО БЫТЬ?ДоСледующегоНовогоГода());        
КонецПроцедуры
 
Функция ДоСледующегоНовогоГода(Прошло,ОбщДни = 365) Экспорт
   Прошло = ДеньГода(ТекущаяДата());
    Возврат ОбщДни - Прошло;
   
КонецФункции


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
И выделяйте код тегом:
Процедура ПриНачалеРаботыСистемы()
   Предупреждение("Загрузилась автоматическая система бомбардировки Пентагона!!!
                  |Нажмите ОК для начала операции наведения",10,"Уничтожение врага средствами 1С");
   Сообщить ("Каюк Америке наступит " + (ТекущаяДата()+60*60));
   Сообщить("С прошлой гранидиозной пьянки прошло "+ДеньГода(ТекущаяДата()) + " дней");
      Сообщить("Дней до Нового года "+ДоСледующегоНовогоГода());       
КонецПроцедуры
 
Функция ДоСледующегоНовогоГода(ОбщДни = 365) Экспорт
   Прошло = ДеньГода(ТекущаяДата()); //Обратите внимание на входящие параметры
    Возврат ОбщДни - Прошло;
   
КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн nr1

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-06
  • Сайт: 
  • Профессия: Ученик 1С
Dethmontt, Ок - не знал просто....
Добавлено: 14 Ноя 2012, 15:53

Цитировать
//Обратите внимание на входящие параметры   
:xfbnsdfb: И?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пока вы научитесь программить... Мне страшно за Америку :lol:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн nr1

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-06
  • Сайт: 
  • Профессия: Ученик 1С
Пока вы научитесь программить... Мне страшно за Америку :lol:
:ooifh: Москва не сразу строилась, а Америку не так-то просто разбомбить ;)
Лучшеб, вот, решение подсказали :D

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Я бы сделал так:

Процедура ПриНачалеРаботыСистемы()
   Предупреждение("Загрузилась автоматическая система бомбардировки Пентагона!!!
                  |Нажмите ОК для начала операции наведения",10,"Уничтожение врага средствами 1С");
   Сообщить ("Каюк Америке наступит " + (ТекущаяДата()+60*60));
   Сообщить("С прошлой гранидиозной пьянки прошло "+ДеньГода(ТекущаяДата()) + " дней");
   Сообщить("Дней до Нового года "+ ДоСледующегоНовогоГода());       
КонецПроцедуры

Функция ДоСледующегоНовогоГода() Экспорт
    ДеньКонцаГода = ДеньГода(КонецГода(ТекущаяДата()));
    Возврат (ДеньКонцаГода +1) - ДеньГода(ТекущаяДата()) ;    //366день в году(31декабря2012) + 1(т.к НГ 1янв)-день тек. даты
КонецФункции
 

Оффлайн nr1

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-06
  • Сайт: 
  • Профессия: Ученик 1С
Gunner, А почему он с параметрами не захотел работать???:xfbnsdfb:

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
nr1, зачем? что вы хотите передавать?
Вот так лучше: Возврат ДеньКонцаГода - ДеньГода(ТекущаяДата()) ;   
день прибавлять не надо

Оффлайн nr1

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-06
  • Сайт: 
  • Профессия: Ученик 1С
зачем? что вы хотите передавать?
То, что передал тогда: Сколько дней осталось и Всего дней в году. Я понимаю, что так, как вы написали - правильно, но хотелось бы все-таки понять - в чем была ошибка. А то вдруг потом придется передавать, а она (функция), опять не примет? ;)

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Я не вижу, чтобы вы что-то передавали.
С параметрами будет так:
Процедура ПриНачалеРаботыСистемы()
   Предупреждение("Загрузилась автоматическая система бомбардировки Пентагона!!!
                  |Нажмите ОК для начала операции наведения",10,"Уничтожение врага средствами 1С");
   Сообщить ("Каюк Америке наступит " + (ТекущаяДата()+60*60));
   Сообщить("С прошлой гранидиозной пьянки прошло "+ДеньГода(ТекущаяДата()) + " дней");
   Прошло = ДеньГода(ТекущаяДата());
   Сообщить("Дней до Нового года "+ ДоСледующегоНовогоГода(Прошло));       
КонецПроцедуры

Функция ДоСледующегоНовогоГода(Прошло, ОбщДни = 365) Экспорт
    Возврат ОбщДни - Прошло;   
КонецФункции


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 319
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal