Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 20:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка в управляемой форме  (Прочитано 8628 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Что я делаю не так?


&НаКлиенте
Процедура Команда1(Команда)
   
   выб =   Справочники.Справочник1.Выбрать();
   
   Пока выб.Следующий()    Цикл
      Сообщить(выб.Наименование);
   КонецЦикла;

   
   
КонецПроцедуры


Ошибка

{Документ.Документ1.Форма.ФормаДокумента.Форма(5,10)}: Переменная не определена (Справочники)
   выб =   <<?>>Справочники.Справочник1.Выбрать(); (Проверка: Тонкий клиент)



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Почитайте хоть что нибудь о нововведениях в 8.2.
Например "Коротко о главном".

"Справочники" не "видны" на клиенте.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
Изменив дерективу на сервере я смогу вывести данные.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Обработчик команды выполняется ТОЛЬКО на клиенте.
RTFM please
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
А как мне в обработчике вывести список номенклатуры нажимая на кнопку.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Нужно из клиентской функции обратиться к серверной и там все сделать.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
В общем модуле написал ошибка переменная не определена Справочникки

 Процедура Ильдар() Экспорт
    выб= Справочники.Справочник1.Выбрать();
   
    Пока выб.Следующий() Цикл
      Сообщить( выб.Наименование);
      КонецЦикла;
   

&НаКлиенте
Процедура Команда1(Команда)
   
ОбщийМодуль1.Ильдар();      
           
КонецПроцедуры


Что нет так.




Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Справочникки

В общем то правильно пишет нет такого ключевого слова, есть ключевое слово "Справочники"

Еще укажите какие галочки у общего модуля проставлены.

Оффлайн Salmishskay2516

  • Это я.
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 1
  • КПД: 0%
  • Регистрация: 2012-11-06
  • Сайт: 
  • Профессия: Ученик 1С
{ОбщийМодуль.ОбщийМодуль1.Модуль(10,8)}: Переменная не определена (Справочники)
    выб= <<?>>Справочники.Справочник1.Выбрать(); (Проверка: Тонкий клиент)


Галочки в общем модуле. Клиент (управляемое приложение). Остальные галочки не выставленны.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Перечитайте еще раз предыдущие сообщения. На клиенте нельзя обращаться к объектам конфигурации.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4530
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6084
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4198
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8499
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8560
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal