Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 11:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УПП 1с 8.2 Где задается параметр ИмяМакета для процедуры печать?  (Прочитано 3205 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vurdalak

  • ***
  • Сообщений: 229
  • РЕПУТАЦИЯ: 8
  • КПД: 3%
  • Регистрация: 2010-08-11
  • Сайт: 
  • Профессия: Ученик 1С
Где задается параметр ИмяМакета для процедуры печать? Платформа 1с 8.2, конфигурация УПП редакция 1.3 ,Документ ЗаказПокупателя, Код Модуля объекта:




Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь) Экспорт


Если ЭтоНовый() Тогда
Предупреждение("Документ можно распечатать только после его записи");
Возврат;
ИначеЕсли Не УправлениеДопПравамиПользователей.РазрешитьПечатьНепроведенныхДокументов(Проведен) Тогда
Предупреждение("Недостаточно полномочий для печати непроведенного документа!");
Возврат;
КонецЕсли;


Если Не РаботаСДиалогами.ПроверитьМодифицированность(ЭтотОбъект) Тогда
Возврат;
КонецЕсли;




// Получить экземпляр документа на печать
Если ИмяМакета = "Заказ" Тогда
ТабДокумент = ПечатьСчетаЗаказа(ИмяМакета);

ИначеЕсли ИмяМакета = "ЗаказСтоимость" тогда
ТабДокумент = ПечатьЗаказСтоимость();

ИначеЕсли ИмяМакета = "ЗаказКорректировка" тогда
ТабДокумент = ПечатьСчетаЗаказаКорректировки(ИмяМакета);
ИначеЕсли ИмяМакета = "Счет" тогда
ТабДокумент = ПечатьСчетаЗаказаКорректировки(ИмяМакета);
ИначеЕсли ИмяМакета = "Бланк" Тогда
ТабДокумент = ПечатьБланк(НаПринтер);
ИначеЕсли ИмяМакета = "ПереченьМатериалов" тогда

Если НЕ(Материалы.Количество() > 0) Тогда
Сообщить("Нет материалов в переработку!");
Возврат;
КонецЕсли;

ТабДокумент = ПечатьПеречняМатериалов(ИмяМакета);
ИначеЕсли ТипЗнч(ИмяМакета) = Тип("ДвоичныеДанные") Тогда


ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(Ссылка, ИмяМакета);

Если ТабДокумент = Неопределено Тогда
Возврат
КонецЕсли;

КонецЕсли;


УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект, Строка(ВидОперации)), Ссылка);


КонецПроцедуры // Печать


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Там где вызывается процедура Печать() первый параметр ИмяМакета
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн vurdalak

  • ***
  • Сообщений: 229
  • РЕПУТАЦИЯ: 8
  • КПД: 3%
  • Регистрация: 2010-08-11
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 861
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal