Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Задать вопрос из серверной процедуры в УФ  (Прочитано 3336 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
В обычных формах была следующая процедура ПередОткрытием() формы:
Если ТипЗнч(ПараметрОснование) = Тип("СправочникСсылка.Организации") Тогда
  
  Запрос = Новый Запрос;
  Запрос.УстановитьПараметр("ВидСвязи"  , Перечисления.ВидыСобственныхКонтрагентов.Организация);
  Запрос.УстановитьПараметр("Основание" , ПараметрОснование);
  
  Запрос.Текст = "
  |ВЫБРАТЬ
  |   Контрагент
  |ИЗ
  |   РегистрСведений.СобственныеКонтрагенты
  |ГДЕ Объект     = &Основание
  |    И ВидСвязи = &ВидСвязи";
  
  Выборка = Запрос.Выполнить().Выбрать();
  
  Если Выборка.Следующий() Тогда
   Отказ = Истина;
   Ответ = Вопрос("Для данной организации уже существует контрагент. Открыть форму?",
   РежимДиалогаВопрос.ДаНет);
   Если Ответ = КодВозвратаДиалога.Да Тогда
    Форма = Выборка.Контрагент.ПолучитьФорму("ФормаЭлемента");
    Форма.Открыть();
   КонецЕсли;
  КонецЕсли;
  
 КонецЕсли;


Пытаюсь ее соорудить на УФ. Пока получилось вот что...

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
 
 Если ТипЗнч(Параметры.Основание) = Тип("СправочникСсылка.Организации") Тогда
  
  Запрос = Новый Запрос;
  Запрос.УстановитьПараметр("ВидСвязи"  , Перечисления.ВидыСобственныхКонтрагентов.Организация);
  Запрос.УстановитьПараметр("Основание" , Параметры.Основание);
  
  Запрос.Текст = "
  |ВЫБРАТЬ
  |   Контрагент
  |ИЗ
  |   РегистрСведений.СобственныеКонтрагенты
  |ГДЕ Объект     = &Основание
  |    И ВидСвязи = &ВидСвязи";
  
  Выборка = Запрос.Выполнить().Выбрать();
  
  Если Выборка.Следующий() Тогда
   //Отказ = Истина;
   //Ответ = Вопрос("Для данной организации уже существует контрагент. Открыть форму?",
   //РежимДиалогаВопрос.ДаНет);
   //Если Ответ = КодВозвратаДиалога.Да Тогда
   // Форма = Контрагент.ПолучитьФорму("ФормаЭлемента");
   // Форма.Открыть();
   //КонецЕсли;
  КонецЕсли;
  
 КонецЕсли;


КонецПроцедуры

с заданием вопроса не знаю что делать....подскажите, пожалуйста.....


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
&НаСервереБезКонтекста
Функция ПроверитьОрганизацию(Организация)

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ВидСвязи"  , Перечисления.ВидыСобственныхКонтрагентов.Организация);
Запрос.УстановитьПараметр("Основание" , Организация);

Запрос.Текст = "
|ВЫБРАТЬ
|   Контрагент
|ИЗ
|   РегистрСведений.СобственныеКонтрагенты 
|ГДЕ Объект     = &Основание
|    И ВидСвязи = &ВидСвязи";

Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Возврат Выборка.Контрагент;
Иначе
Возврат Справочники.Контрагенты.ПустаяСсылка();
КонецЕсли;

КонецФункции // ПроверитьОрганизацию()


&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Если ТипЗнч(Параметры.Основание) = Тип("СправочникСсылка.Организации") Тогда
    
      КонтрагентПоОрганизации = ПроверитьОрганизацию(Параметры.Основание); 
     
      Если ЗначениеЗаполнено(КонтрагентПоОрганизации) Тогда
     
         Отказ = Истина;
         Ответ = Вопрос("Для данной организации уже существует контрагент. Открыть форму?",
         РежимДиалогаВопрос.ДаНет);
         Если Ответ = КодВозвратаДиалога.Да Тогда
            Форма = КонтрагентПоОрганизации.ПолучитьФорму("ФормаЭлемента");
            Форма.Открыть();
         КонецЕсли;
     
      КонецЕсли;
     
   КонецЕсли;
КонецПроцедуры



с "Если ТипЗнч(Параметры.Основание) = Тип("СправочникСсылка.Организации") Тогда" - большие сомнения.
отработает ли на клиенте. но тоже решаемо...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Если ТипЗнч(Параметры.Основание) = Тип("СправочникСсылка.Организации") Тогда не отрабатывает на клиенте....Не знает, он что такое Параметры.Основание....Это тока ПриСозданииНаСервере я поняла можно получить


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9235
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Вопрос по РИБ "ПоОрганизации"

Автор andi_xРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 5856
Последний ответ 15 Мар 2013, 21:38
от Besart
Вопрос по "Отчеты о Розничных продажах".

Автор GerCerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3294
Последний ответ 26 Июл 2010, 16:06
от crow1983
Вопрос о действии кнопки "Записать"

Автор jenya1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3455
Последний ответ 06 Окт 2014, 15:23
от jenya1111
Вопрос по отчету "Материалы в эксплуатации".

Автор mitauskasРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 2372
Последний ответ 04 Мар 2015, 11:07
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal