Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отсутствует кнопка печать  (Прочитано 7445 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ofautum

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Типовая Бухгалтерия для Казахстана 8.2 (2.0.8.17). Создавал печатную форму для вновь созданного документа. Отсутствует кнопка "Печать".
Печатная форма создавалась таким образом: Создал в "группе команд", команду печать, внутри ветви "общие" дерева конфигурации. В самом документе, на вкладке "Макеты" ---конструктор печати, в открывшемся окне указываем, что создается новая команда. Далее из реквизитов выбираем те, которые хотим видеть на печатной форме. На последнем этапе указываем, что создаваемая конструктором команда будет входить в ранее созданную нами группу "печать" В результате работы конструктора у объекта конфигурации была создана команда.

В модуле команды определен следующий код:


&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
ТабДок = Новый ТабличныйДокумент;
Печать(ТабДок, ПараметрКоманды);

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
//}}
КонецПроцедуры


&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Документы.ЗаявкаНаПеревозкуГруза.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры

В модуле менеджера документа:


Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.ЗаявкаНаПеревозкуГруза.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаНаПеревозкуГруза.ВалютаПлатежа,
| ЗаявкаНаПеревозкуГруза.Водитель,
| ЗаявкаНаПеревозкуГруза.ГрузоотправительИАдресПунктаВыгрузки,
| ЗаявкаНаПеревозкуГруза.ГрузополучательИАдресПунктаВыгрузки,
| ЗаявкаНаПеревозкуГруза.Дата,
| ЗаявкаНаПеревозкуГруза.ДатаДоставки,
| ЗаявкаНаПеревозкуГруза.ДатаПогрузки,
| ЗаявкаНаПеревозкуГруза.КонтактноеЛицоВПунктеВыгрузки,
| ЗаявкаНаПеревозкуГруза.КонтактноеЛицоВПунктеПогрузки,
| ЗаявкаНаПеревозкуГруза.МаркаМашины,
| ЗаявкаНаПеревозкуГруза.МаршрутПеревозки,
| ЗаявкаНаПеревозкуГруза.ОсобенностиГруза,
| ЗаявкаНаПеревозкуГруза.ПаспортДатаИМестоВыдачиДокумента,
| ЗаявкаНаПеревозкуГруза.РастамаживаниеГруза,
| ЗаявкаНаПеревозкуГруза.СтоимостьГруза,
| ЗаявкаНаПеревозкуГруза.СтоимостьПеревозки,
| ЗаявкаНаПеревозкуГруза.ТипИКоличествоПодвижногоСостава,
| ЗаявкаНаПеревозкуГруза.УсловияВыгрузки,
| ЗаявкаНаПеревозкуГруза.УсловияОплаты,
| ЗаявкаНаПеревозкуГруза.УсловияПогрузки,
| ЗаявкаНаПеревозкуГруза.УсловияПростоя,
| ЗаявкаНаПеревозкуГруза.ХарактерГруза
|ИЗ
| Документ.ЗаявкаНаПеревозкуГруза КАК ЗаявкаНаПеревозкуГруза
|ГДЕ
| ЗаявкаНаПеревозкуГруза.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

В режиме 1с предприятие, при заполнение документа, как я уже писал, отсутствует кнопка "Печать". Подскажите как быть? 
Спасибо 


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Посмотрите есть ли эта кнопка в конфигураторе на форме.

Оффлайн ofautum

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Посмотрите есть ли эта кнопка в конфигураторе на форме.

Нет, на форму кнопку я еще не добавлял. Дело в том, что даже сравнивая документы типовой конфигурации, на них тоже кнопки печать в конфигураторе нет, а в режиме Предприятия есть.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Открываете редактор формы.
Вверху слева список элементов управления формы.
Выбираем вкладку "Командный интерфейс".
В ветке "Командная панель" должны видеть подветку "Печать".
Раскрываем и видим вашу команду.
Осталось проверить флажки видимости...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ofautum

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-23
  • Сайт: 
  • Профессия: Ученик 1С
Открываете редактор формы.
Вверху слева список элементов управления формы.
Выбираем вкладку "Командный интерфейс".
В ветке "Командная панель" должны видеть подветку "Печать".
Раскрываем и видим вашу команду.
Осталось проверить флажки видимости...

Вот скрин, нет вкладки "Командный интерфейс". Как мне его увидеть?
Добавлено: 30 Окт 2012, 16:25

Открываете редактор формы.
Вверху слева список элементов управления формы.
Выбираем вкладку "Командный интерфейс".
В ветке "Командная панель" должны видеть подветку "Печать".
Раскрываем и видим вашу команду.
Осталось проверить флажки видимости...

Все разобрался почему у меня нет "Командного интерфейса". ФОрма была создана простая, а не управляемая. Но пока еще не доделал, завтра с утра продолжу. Так что скорее всего еще будут вопросы :). Спасибо
 

Последний раз редактировалось: ofautum; 30 Окт 2012, 16:25


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 682
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal