Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 13:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ограничение на значения в регистре сведений  (Прочитано 2777 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн oagafonov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-20
  • Сайт: 
  • Профессия: Разработчик 1С
Имеется регистр сведений. Изменениями выступают: справочник сотрудников и число (год). Ресурс - кол-во дней.
Есть ограничение на сумму по ресурсу. Т.е. суммарное количество дней по заданному сотруднику в заданному году не может быть больше указанного числа (например, 44 дней).

Как это ограничение лучше всего реализовать?

Что пробовал: пробовал в модуле набора записей реализовать процедуру ОбработкаПроверкиЗаполнения. Здесь возникает проблема отделения добавляемой записи от изменяемой записи для того, чтобы правильно вычислить сумму.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Как вариант очищать изменяемую запись оставляя ее только на форме
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Чем не нравится оборотный регистр накопления?
И не нужно измерения "Год".
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн oagafonov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-20
  • Сайт: 
  • Профессия: Разработчик 1С
Цитата: cska-fanat-kz
Чем не нравится оборотный регистр накопления?
И не нужно измерения "Год".
Нет желания использовать документ. Предполагается работать с данными регистра в форме списка этого же регистра.

При использовании документа, задача как бы снимается сама собой, поскольку на этапе проведения документа можно обратиться к регистру и получить все что нужно. Этот вариант я держу в уме, если не получиться решить проблему.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Процедура ПередЗаписью(Отказ, Замещение)
   Для каждого ЗаписьРегистра Из ЭтотОбъект Цикл
      Если ЗаписьРегистра.ВашеИзмерение > 44 Тогда
         Сообщить("Нельзя указывать значения больше 44");
         Отказ = Истина;
         Возврат
      КонецЕсли;   
   КонецЦикла;   
КонецПроцедуры
Добавлено: 29 Окт 2012, 17:25

а, да, забыл: клд надо вставить в модуль объекта.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
mixqn, у него СУММА по количеству не должна превышать 44, а не текущее значение...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Цитата: cska-fanat-kz
mixqn, у него СУММА по количеству не должна превышать 44, а не текущее значение...
не обратил внимания...
тогда, алгоритм будет сложнее. надо предварительно выгрузить набор записей в таблицу значений, сформировать запрос по ключевым полям и получить текущее значение суммы (до записи нового набора)по каждому сочетанию "сотрудник-год" в виде таблицы значений. далее обходя в цикле записи набора изменять значение суммы и сверять его с 44, учитывая то, что запись с такими ключевыми полями может уже быть - то есть по всей видимости таблица должна хранить не итоги в разрезе "сотрудник-год", а все записи регистра с соответствующими значениями полей "сотрудник-год". как-то так. в общем надо начать писать и отлаживать и там наверно станет понятно, как быть.


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 283
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4848
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7746
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9360
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 985
Последний ответ 11 Июл 2016, 09:00
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
46 Сообщений
AIFrame
46 Сообщений
andron81_81
41 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal