Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 10:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызов макетов документа  (Прочитано 8323 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Я создал для одного документа несколько макетов. Можно ли вызватьвсе макеты этого документа, чтоб пользователь выбрал себе нужней макет для
печати.


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Через метаданные программно можно получить список макетов...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Через метаданные программно можно получить список макетов...
какой нибудь пример можите показать или ссылку

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
     
Мет = Ссылка.Метаданные();
      Для каждого Макет Из Мет.Макеты Цикл
     
         Сообщить(Макет.Имя);
     
      КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
      Код: [Выделить]Мет = Ссылка.Метаданные();
      Для каждого Макет Из Мет.Макеты Цикл
     
         Сообщить(Макет.Имя);
     
      КонецЦикла;

Для каждого Макет Из Метаданные.Документы.ГениралнийДоговор1.Макеты Цикл
   Сообщить(Макет.Представление());    
    КонецЦикла;

В сообщение выводить макеты но как вывести в списке для выбора 

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ЭлементыФормы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
ЭлементыФормы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());
Ошибка вышла
{Документ.ГениралнийДоговор1.Команда.Печать.МодульКоманды(26,2)}: Переменная не определена (ЭлементыФормы)
   <<?>>ЭлементыФормы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());     (Проверка: Сервер)


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Цитата: Sparrow Rix
Цитата: cska-fanat-kz от Сегодня в 10:46:54ЭлементыФормы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());Ошибка вышла
{Документ.ГениралнийДоговор1.Команда.Печать.МодульКоманды(26,2)}: Переменная не определена (ЭлементыФормы)
   <<?>>ЭлементыФормы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());     (Проверка: Сервер)\\

А вы на управляемых формах сидите? Тогда надо Элементы.ПолеСпискаМакетов..... и так далее.... Ведь предупреждать про них надо.))))

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Одна и тажа ошибка.Посмотрите я правильно пишу код
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    СписокМакетов();
КонецПроцедуры

&НаСервере
Процедура СписокМакетов()
   Для каждого Макет Из Метаданные.Документы.ГениралнийДоговор1.Макеты Цикл
   Элементы.ПолеСпискаМакетов.СписокВыбора.Добавить(Макет.Имя, Макет.Представление());          
   КонецЦикла;
КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"Та же ошибка" быть не может потому что у вас в коде нет уже "ЭлементыФормы" ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4467
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15899
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 616
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7730
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal