Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 20:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Построение отчета  (Прочитано 1806 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Feramount

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-26
  • Сайт: 
  • Профессия: Программист 7.7
Делаю отчет в 1С вот таким вот образом
Процедура Сформировать()
Таблица=СоздатьОбъект("Таблица");
СписокНаименований = СоздатьОбъект("Справочник.СправочникНоменклатура");
СписокСкладов = СоздатьОбъект("Справочник.СправочникСклады");
Таблица.ИсходнаяТаблица("ОтчетПоОстаткам");
СписокНаименований.ВыбратьЭлементы(0);
Таблица.ВывестиСекцию("Заголовок");
Пока СписокНаименований.ПолучитьЭлемент(1)=1 Цикл
НаименованиеТовара=СписокНаименований.Наименование;
Таблица.ВывестиСекцию("Общее");
СписокСкладов.ВыбратьЭлементы(0);
Пока СписокСкладов.ПолучитьЭлемент(1)=1 Цикл
РегОстатков=СоздатьОбъект("Регистр.РегистрОстатков");
ИмяТовара=СокрЛП(СписокНаименований.Наименование);
ИмяСклада=СокрЛП(СписокСкладов.Наименование);
НазваниеСклада=ИмяСклада;
РегОстатков.Остатки(ИмяТовара, ИмяСклада);
ОстатокПоСкладу=РегОстатков.Количество;
Таблица.ВывестиСекцию("Склады");
КонецЦикла;
КонецЦикла;
Таблица.Показать();
КонецПроцедуры;
Отчет выводит нормально, но количество товаров по каждому складу выводи как нулевое значение, хотя товары на складе есть.В чем ошибка?


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
В метод Остатки() нужно передавать объекты, а не наименования товара и склада.
Компьютер не умеет читать мысли, для него текст это текст, он не поймет что передаваемый текст это
на самом деле элемент справочника "Товары" или склада.

и зачем  каждый раз в цикле создавать объект  РегОстатков=СоздатьОбъект("Регистр.РегистрОстатков")?
Достаточно один раз создать перед циклами.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 282
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal