Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 00:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сортировка таблицы значений  (Прочитано 7268 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DZenav

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-26
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет!
Есть готовая таблица. -> Процедура Заполнение(Кнопка)
   
   
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Номер",Новый ОписаниеТипов("Число"));
ГСЧ = Новый ГенераторСлучайныхЧисел();
Для Сч=1 По 49 Цикл
Строки=ТаблицаЗначений.Добавить();
Строки.Номер = ГСЧ.СлучайноеЧисло(1,99);
КонецЦикла;

ЭлементыФормы.ТаблПоле.Значение=ТаблицаЗначений;
ЭлементыФормы.ТаблПоле.СоздатьКолонки();
КонецПроцедуры

Хочу чтоб с другой кнопки можно было отсортировать таблицу пузырьком. Вот код ->

Функция СортировкаПузырьком(Элемент) Экспорт
   
    Для Просм = 0 По Элемент.Количество()-1 Цикл
               Для Значение = 0 По Элемент.Количество()-1 Цикл
               Если Значение = Элемент.Количество()-1 Тогда
               Прервать;
               КонецЕсли;
               Если Элемент[Значение] > Элемент[Значение+1] Тогда
               СтаршийЭлемент = Элемент[Значение];
               МладшийЭлемент = Элемент[Значение+1];
               Элемент[Значение] = МладшийЭлемент;
               Элемент[Значение+1] = СтаршийЭлемент;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
    Возврат Элемент;
КонецФункции


Процедура СортировкаПерестановкой(Кнопка)
   
    Элемент = Новый ТаблицаЗначений;
    Элемент.Колонки.Добавить("Номер",Новый ОписаниеТипов("Число"));
    ГСЧ = Новый ГенераторСлучайныхЧисел();
    Для Сч=1 По 49 Цикл
        Строки=Элемент.Добавить();
        Строки.Номер = ГСЧ.СлучайноеЧисло(1,99);
    КонецЦикла;
   
    СортировкаПузырьком(Элемент);
    ЭлементыФормы.ТаблПоле.Значение = Элемент;   
    ЭлементыФормы.ТаблПоле.СоздатьКолонки();
   
КонецПроцедуры

Помогите исправить  Процедура СортировкаПерестановкой(Кнопка) и Функция СортировкаПузырьком(Элемент)

Последний раз редактировалось: MuI_I_Ika; 26 Окт 2012, 15:52


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Можно поинтересоваться: вы с какой целью свой алгоритм сортировки пишите? С целью повышения образованности (с) - научиться реализовывать алгоритм сортировки пузырьком? Стандартный метод Сортировать() чем не годится?

Оффлайн DZenav

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-26
  • Сайт: 
  • Профессия: Ученик 1С
Хочу научиться именно пузырьком. сама функция простая, но не получаеться все расставить на свои места.


 

"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 730
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4665
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 20705
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6212
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1049
Последний ответ 10 Фев 2017, 10:49
от ksander-fars

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal