Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 09:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не знаю, как посчитать  (Прочитано 2680 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Не знаю :dfbsdfbsdf:, как посчитать количество товара. Если не трудно напишите код. Обе таблицы табличные части документа


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
КопияТЧ = ТЧ.Скопировать();
КопияТЧ.Свернуть("ВидТовараНаименование","Количество");
Для каждого Стр Из КопияТЧ Цикл
Сообщить("Вид товара :"+Стр.ВидТовараНаименование+" ИТОГО: "+Стр.Количество);
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Выгрузка = ТЧ2.Выгрузить();

Выгрузка.Свернуть("ВидТовара","Количество");

Для каждого Элемент из ТЧ1 Цикл

   ИскомаяСтрока = Выгрузка.Найти(Элемент.Наименование,"ВидТовара");

   Если ИскомаяСтрока <> Неопределено Тогда
      Элемент.ОбщееКоличество = ИскомаяСтрока.Количество;
   КонецЕсли;

КонецЦикла;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
КопияТЧ = ТЧ.Скопировать();
КопияТЧ.Свернуть("ВидТовараНаименование","Количество");
ТЧВидТовара.Загрузить(КопияТЧ); //в этом случае имена колонок в ТЧ ВидТовара должны бить 1.ВидТовараНаименование 2.Количество
Добавлено: 25 Окт 2012, 15:01

Оперативненько =))  :D
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Выгрузка = Подробней.Выгрузить();

 ВидТовара=Объект.ВидТовара;
    Подробней=Элементы.Подробней;
   Выгрузка = Подробней.Выгрузить();

Выгрузка.Свернуть("ВидТовара","Количество");

Для каждого Элемент из ВидТовара Цикл

   ИскомаяСтрока = Выгрузка.Найти(Элемент.Наименование,"ВидТовара");

   Если ИскомаяСтрока <> Неопределено Тогда
      Элемент.ОбщееКоличество = ИскомаяСтрока.Количество;
   КонецЕсли;

КонецЦикла;

выдает ошибка {Документ.Документ1.Форма.ФормаДокумента.Форма(21)}: Метод объекта не обнаружен (Выгрузить)
Добавлено: 25 Окт 2012, 15:38

Выгрузка = Подробней.Выгрузить();

 ВидТовара=Объект.ВидТовара;
    Подробней=Элементы.Подробней;
   Выгрузка = Подробней.Выгрузить();

Выгрузка.Свернуть("ВидТовара","Количество");

Для каждого Элемент из ВидТовара Цикл

   ИскомаяСтрока = Выгрузка.Найти(Элемент.Наименование,"ВидТовара");

   Если ИскомаяСтрока <> Неопределено Тогда
      Элемент.ОбщееКоличество = ИскомаяСтрока.Количество;
   КонецЕсли;

КонецЦикла;

выдает ошибка {Документ.Документ1.Форма.ФормаДокумента.Форма(21)}: Метод объекта не обнаружен (Выгрузить)
Написал в Процедура ПодробнейКоличествоПриИзменении

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Посмотри как тут
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Как посчитать сумму в колонках ТЧ отчета в расчетно платежной ведомости?

Автор Vladimir369Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 731
Последний ответ 16 Фев 2017, 12:41
от Vladimir369
Помогите посчитать сумму в табличной части

Автор mishasibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8641
Последний ответ 02 Апр 2012, 14:56
от cska-fanat-kz
Отчет на СКД ( как посчитать значение ресурса в группировке )

Автор starz555Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 7323
Последний ответ 22 Окт 2013, 17:21
от starz555
Посчитать количество свободных мест на складе

Автор jenek1221Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1768
Последний ответ 28 Окт 2013, 09:18
от wise
Как посчитать стоимость всех работ в форме?

Автор keramikРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 2303
Последний ответ 06 Окт 2014, 23:00
от keramik

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
45 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 686
  • Точка Скрытых: 0
  • Точка Пользователей: 19
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal