Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 02:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Срочно нужна помощь новичку  (Прочитано 4233 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
Не знаю :dfbbdrfb:, как сделать, чтобы при выборе "Объекта страхования" менялись данные в "Страховые риски". "Объекта страхования" и "Страховые риски" табличная часть документа.
Информационная база http://transinsuranceplus.com/1Cv8.dt



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
в запрос к списку страховых рисков добавьте условие на объект страхования.
и в событии ПриАктивизацииСтроки() списка объектов страхования его устанавливайте.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
в запрос к списку страховых рисков добавьте условие на объект страхования.
Как это сделать

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если это динамический список то нужно написать произвольный запрос с условием
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
список страховых рисков - динамический список на произвольном запросе...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
 "Страховые риски" это табличная часть документа
Добавлено: 24 Окт 2012, 13:47

запрос с условием
можете написать мне запрос с условием

Последний раз редактировалось: Sparrow Rix; 24 Окт 2012, 13:47

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"ОбъектСтр" ТЧ "Страховые риски" сделайте типа СправочникСсылка.ТипыОбъектовСтрахования.

и событие ПриАктивизацииСтроки() ТЧ "ОбъектыСтрахования" обрабатывайте например так:

&НаКлиенте
Процедура ОбъектыСтрахованияПриАктивизацииСтроки(Элемент)
   ТекОбъектСтр = Элементы.ОбъектыСтрахования.ТекущиеДанные.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;
КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
"ОбъектСтр" ТЧ "Страховые риски" сделайте типа СправочникСсылка.ТипыОбъектовСтрахования.

и событие ПриАктивизацииСтроки() ТЧ "ОбъектыСтрахования" обрабатывайте например так:

&НаКлиенте
Процедура ОбъектыСтрахованияПриАктивизацииСтроки(Элемент)
   ТекОбъектСтр = Элементы.ОбъектыСтрахования.ТекущиеДанные.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;
КонецПроцедуры

работает но в начале выдает ошибку {Документ.ГениралнийДоговор1.Форма.ФормаДокумента.Форма(84)}: Значение не является значением объектного типа (ТипыОбъектовСтрахования)
ТекОбъектСтр = Элементы.ОбъектыСтрахования.ТекущиеДанные.ТипыОбъектовСтрахования; из за чего?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
попробуйте

ТекОбъектСтр = Элементы.ОбъектыСтрахования.ТекущиеДанные.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;

заменить на

СтрокаТЧ = Элементы.ОбъектыСтрахования.ТекущиеДанные;
Если СтрокаТЧ <> Неопределено Тогда
   ТекОбъектСтр = СтрокаТЧ.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;
КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Sparrow Rix

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-24
  • Сайт: 
  • Профессия: Ученик 1С
попробуйте

ТекОбъектСтр = Элементы.ОбъектыСтрахования.ТекущиеДанные.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;

заменить на

СтрокаТЧ = Элементы.ОбъектыСтрахования.ТекущиеДанные;
Если СтрокаТЧ <> Неопределено Тогда
   ТекОбъектСтр = СтрокаТЧ.ТипыОбъектовСтрахования;
   СтруктураОтбораСтрок = Новый ФиксированнаяСтруктура("ОбъектСтр", ТекОбъектСтр);
   Элементы.СтраховыеРиски.ОтборСтрок = СтруктураОтбораСтрок;
КонецЕсли;
Огромное вам спасибо все отлично работает


Теги:
 

Необходима помощь в создании обработки "Внутренний заказ"

Автор miliamРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5194
Последний ответ 28 Апр 2013, 20:26
от Besart
Нужна ВПФ - дайте рыбу "СчетНаОплатуПокупателю" для 1с 8.2. УТ 10

Автор Anton99Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3329
Последний ответ 09 Окт 2011, 20:25
от Anton99
Кому нужна инф. по конфе "Конвертация"

Автор ВоронкинРаздел Закрытые темы

Ответов: 2
Просмотров: 3818
Последний ответ 09 Фев 2012, 19:38
от Столяр
Нужна консультация по "Бухгалтерия для Украины", редакция 1.0. Первое событие

Автор nopРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2029
Последний ответ 25 Окт 2010, 15:17
от nop
Перенесено: нужна внешняя обработка для ПКО "Печать квитанции об уплате..."

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2290
Последний ответ 10 Фев 2012, 07:45
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 137
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal