Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ограничения прав на создание документа задним числом  (Прочитано 5073 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Бухгалтерия 8.2 для Украины

Люди добрые помогите плз...
Нужно в РТУ установить ограничение на создание документа задним числом... для одной роли... если не сложно объясните плз !

p.s. Без использования  функции  "Дата запрета редактирования"


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
кодом в модуле объекта проверяйте РольДоступна и дату, выдавайте сообщение, запись отменяйте (Отказ=Истина)

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Решил данную задачу вот таким не ординарным способом...
 
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)   
   
   Документ=Метаданные.Документы.РеализацияТоваровУслуг.Проведение;
   Если
      Дата < РабочаяДата
   И
   НЕ   РольДоступна("Просмотр")
   Тогда
      Дата = 15.1989
   КонецЕсли;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А так нельзя?

Если Дата < РабочаяДата И НЕ РольДоступна("Просмотр") Тогда
Сообщить("Нельзя создавать документ задним числом");
Отказ = ИСТИНА;
КонецЕсли;

Пользователю хотя бы понятно почему документ не записался
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
 :lol: :)
Добавлено: 25 Окт 2012, 13:52

Далее если кого то заинтересует...
Сделал ограничение на редактирование проведенных

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если Проведен
   И НЕ РольДоступна("Просмотр")
   Тогда
   ТолькоПросмотр=Истина
КонецЕсли;

Последний раз редактировалось: EritikWoW; 25 Окт 2012, 13:52

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Походу Автора интересует общение только с самим собой..... (
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн EritikWoW

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2012-03-19
  • Сайт: 
  • Профессия: Ученик 1С
Походу Автора интересует общение только с самим собой..... (

Нет =) Огромное спс за корректировку кода... действительно красивее и более грамотно =)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15911
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 621
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7739
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 845
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal