Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 19:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управляемые формы  (Прочитано 2900 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Подскажите, пожалуйста...раньше в обычных формах была процедура
Процедура БанковскиеСчетаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   
   Если ДанныеСтроки <> Неопределено Тогда
      СсылкаСтроки = ДанныеСтроки.Ссылка;
   Иначе
      СсылкаСтроки = Неопределено;
   КонецЕсли;
   
   Если ДанныеСтроки <> Неопределено И НЕ СсылкаСтроки.Пустая() И ЭтотОбъект.ОсновнойБанковскийСчет = СсылкаСтроки Тогда
      ОформлениеСтроки.Шрифт = мЖирныйШрифт;
   КонецЕсли;
   
КонецПроцедуры


Если банковский счет в табличной части являлся основным, то он подсвечивался жирным....как это реализовать на уф?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
спасибо!!! а как там условие вот это ЭтотОбъект.ОсновнойБанковскийСчет = СсылкаСтроки поставить? Слева я могу выбрать ссылка (мой банковский счет) а справа мне не указать ЭтотОбъект.ОсновнойБанковскийСчет (((((

Динамический список заполняется запросом:
ВЫБРАТЬ
   СправочникБанковскиеСчета.Ссылка,
   СправочникБанковскиеСчета.ВерсияДанных,
   СправочникБанковскиеСчета.ПометкаУдаления,
   СправочникБанковскиеСчета.Предопределенный,
   СправочникБанковскиеСчета.Владелец,
   СправочникБанковскиеСчета.Код,
   СправочникБанковскиеСчета.Наименование,
   СправочникБанковскиеСчета.НомерСчета,
   СправочникБанковскиеСчета.Банк,
   СправочникБанковскиеСчета.БанкДляРасчетов,
   СправочникБанковскиеСчета.ТекстКорреспондента,
   СправочникБанковскиеСчета.ТекстНазначения,
   СправочникБанковскиеСчета.ВидСчета,
   СправочникБанковскиеСчета.ВалютаДенежныхСредств,
   СправочникБанковскиеСчета.НомерИДатаРазрешения,
   СправочникБанковскиеСчета.ДатаОткрытия,
   СправочникБанковскиеСчета.ДатаЗакрытия,
   СправочникБанковскиеСчета.МесяцПрописью,
   СправочникБанковскиеСчета.СуммаБезКопеек
ИЗ
   Справочник.БанковскиеСчета КАК СправочникБанковскиеСчета
ГДЕ
   СправочникБанковскиеСчета.Владелец = &ВладелецСчета

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
?????????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Добавьте в запрос еще одно поле с текстом
ВЫБОР
КОГДА Ссылка = Владелец.ОсновнойБанковскийСчет
ТОГДА Истина
ИНАЧЕ Ложь
КОНЕЦ КАК ЭтоОсновной

(текст по памяти набрал - если что, откорректируйте)
и по нему и делайте оформление
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
спасибо, разобралась...


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 630
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 154
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5256
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3798
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5792
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений

* Кто онлайн

  • Точка Гостей: 308
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal